Announcement Announcement Module
Collapse
No announcement yet.
Found 0 <bean> elements Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Found 0 <bean> elements

    In my web app Spring is init'd via ContextLoaderServlet. My beans are defined in the default applicationContext.xml. Spring is finding the file but reports there are no bean definitions. I've double-checked and there is only one applicationContext.xml in my project, under WEB-INF. Everything looks normal. Anyone know what's going on?

    <servlet>
    <servlet-name>context</servlet-name>
    <servlet-class>org.springframework.web.context.ContextLoade rServlet</servlet-class>
    <load-on-startup>1</load-on-startup>
    </servlet>

    (I need to use ContextLoaderServlet because I am using Orion/Oracle)

    The problem:

    (ContextLoader:146) Root WebApplicationContext: initialization started
    (XmlBeanDefinitionReader:153) Using JAXP implementation[[email protected]]
    (XmlBeanDefinitionReader:158) Loading XML bean definitions from ServletContext resource [/WEB-INF/applicationContext.xml]
    (BeansDtdResolver:50) Trying to resolve XML entity with public ID [-//SPRING//DTD BEAN//EN] and system ID [http://www.springframework.org/dtd/spring-beans.dtd]
    (BeansDtdResolver:56) Trying to locate [spring-beans.dtd] in Spring jar
    (BeansDtdResolver:64) Found beans DTD [http://www.springframework.org/dtd/spring-beans.dtd] in classpath
    (DefaultXmlBeanDefinitionParser:173) Loading bean definitions
    (DefaultXmlBeanDefinitionParser:181) Default lazy init 'false'
    (DefaultXmlBeanDefinitionParser:182) Default autowire 'no'
    (DefaultXmlBeanDefinitionParser:183) Default dependency check 'none'
    (DefaultXmlBeanDefinitionParser:188) Found 0 <bean> elements in ServletContext resource [/WEB-INF/applicationContext.xml]
    (AbstractBeanDefinitionReader:143) Loaded 0 bean definitions from location pattern [/WEB-INF/applicationContext.xml]

  • #2
    Please disregard

    This was resolved, though I'm not sure how.

    Comment

    Working...
    X