Announcement Announcement Module
Collapse
No announcement yet.
Creating MVC project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Creating MVC project

    I asked this question before in a round about way and never got a conclusive answer so forgive me for asking again more directly. I create a Spring MVC Template project from the "Spring Template Project" link on the STS Dashboard (under Eclipse Juno, with Spring STS 3.8 + 4.2). I enter a project name and top-level package name. If I enter a top-level package of more than 3 levels, for example com.proj.test.mike I get packages: com, com.proj, and com.proj.test but no com.proj.test.mike. I have the option to show empty packages enabled. Further, if I check on the context root in Properties->WebProject settings the value is "test" when I would expect "mike". There seems to be an issue with declaring your top-level project with more than 3 levels. If I create the project with the top level package com.proj.test, then it works as expected and the context root is now "test". Is this an issue with the STS or something else?

    Thanks
    Last edited by MikeT; Apr 4th, 2013, 03:00 PM. Reason: Correction

  • #2
    I am also encountering this problem when using Spring Template Project.

    I am using Spring Toolsuite v3.2.0.RELEASE

    I need a 4 top level project since this was required by the client. jp.co.xxxx.yyyy

    The only workaround I know and did was to manually create the missing packages and changed the context-name.
    I really don't want to do this since I don't know if there's setting I miss.

    Thank you

    Comment


    • #3
      Originally posted by wahoho View Post
      I am also encountering this problem when using Spring Template Project.

      I am using Spring Toolsuite v3.2.0.RELEASE

      I need a 4 top level project since this was required by the client. jp.co.xxxx.yyyy

      The only workaround I know and did was to manually create the missing packages and changed the context-name.
      I really don't want to do this since I don't know if there's setting I miss.

      Thank you
      Thanks for the confirmation.

      Comment

      Working...
      X