Announcement Announcement Module
Collapse
No announcement yet.
Problems with the web development environment:Eclipse+Spring3.2+tomcat7.0.34 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with the web development environment:Eclipse+Spring3.2+tomcat7.0.34

    I'm new in web development with Spring.Today when I test my first spring web app, it throws an exception like that:
    java.lang.ClassNotFoundException: org.springframework.core.env.EnvironmentCapable

    The project dosen't use maven.I put all the spring3.2 jars into the "/WEB-INF/lib/" dictionary.And I really find the class
    "org.springframework.core.env.EnvironmentCapab le" in spring-core-3.2.0.RELEASE.jar, which is one of the spring3.2 jars.So, I couldn't understand the app says it can't find the org.springframework.core.env.EnvironmentCapable class.
    And When I visit the address "http://localhost:8080/myfirstapp/hello.do", using my browser, it also returns the page which contains the error information like above.

    So, is there anybody who encounters such trouble like me?How you resolve it?Thanks a lot.
Working...
X