Announcement Announcement Module
Collapse
No announcement yet.
Project from tomcat 6 to 7 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Project from tomcat 6 to 7

    I have a project that runs on tomcat 6.

    locally i want this to upgrade to tomcat 7

    heres my pom.xml dependencies.. quite simple though when i try to run this in tomcat 7, it seems my controller annotation is not scanned and read..

    is there a huge difference with the tomcat versions???
    my dependecies are quite standard.

    Code:
    	<properties>
    		<spring.version>3.0.5.RELEASE</spring.version>
    	</properties>
    
    	<dependencies>
    
    		<dependency>
    			<groupId>junit</groupId>
    			<artifactId>junit</artifactId>
    			<version>4.10</version>
    		</dependency>
    
    		<!-- Spring 3 dependencies -->
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-core</artifactId>
    			<version>${spring.version}</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-web</artifactId>
    			<version>${spring.version}</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-webmvc</artifactId>
    			<version>${spring.version}</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-orm</artifactId>
    			<version>3.0.5.RELEASE</version>
    		</dependency>
    
    
    		<!-- MySQL database driver -->
    		<dependency>
    			<groupId>mysql</groupId>
    			<artifactId>mysql-connector-java</artifactId>
    			<version>5.1.9</version>
    		</dependency>
    
    		<!-- Hibernate framework -->
    		<dependency>
    			<groupId>org.hibernate</groupId>
    			<artifactId>hibernate</artifactId>
    			<version>3.2.3.ga</version>
    		</dependency>
    
    
    		<!-- Hibernate library dependecy start -->
    		<dependency>
    			<groupId>dom4j</groupId>
    			<artifactId>dom4j</artifactId>
    			<version>1.6.1</version>
    		</dependency>
    
    		<dependency>
    			<groupId>commons-logging</groupId>
    			<artifactId>commons-logging</artifactId>
    			<version>1.1.1</version>
    		</dependency>
    
    		<dependency>
    			<groupId>commons-collections</groupId>
    			<artifactId>commons-collections</artifactId>
    			<version>3.2.1</version>
    		</dependency>
    
    		<dependency>
    			<groupId>antlr</groupId>
    			<artifactId>antlr</artifactId>
    			<version>2.7.7</version>
    		</dependency>
    
    	</dependencies>

  • #2
    quite simple though when i try to run this in tomcat 7, it seems my controller annotation is not scanned and read..
    Check the Tomcat's log files to see if exists more details.

    Comment

    Working...
    X