Announcement Announcement Module
Collapse
No announcement yet.
Spring MVC with WebLogic 10.3.4 - getting an HTTP 406 on GET request w/ @ResponseBody Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring MVC with WebLogic 10.3.4 - getting an HTTP 406 on GET request w/ @ResponseBody

    Hi there. I am building a Spring-MVC application with Spring 3.1.1 and I am using Jackson 2.0.1 and I have a controller that uses the @ResponseBody annotation to return JSON.

    Code:
        @RequestMapping(value="/roleMaint/role/roleTypes", method = RequestMethod.GET)
        public @ResponseBody List<Model> getRoleTypes() {
    
            List<Model> roleModels = new ArrayList<Model>();
    
            List<RoleType> roleTypes = Arrays.asList(RoleType.values());
            for (RoleType roleType : roleTypes) {
                ExtendedModelMap model  = new ExtendedModelMap();
                model.addAttribute("name", roleType.name());
                roleModels.add(model);
            }
            return roleModels;
        }
    I have the following items in my servlet configuration

    Code:
        <mvc:annotation-driven/>
        <mvc:default-servlet-handler/>
    When I execute a GET request, I get an HTTP 406 from WebLogic 10.3.4, which is the Java container I am deploying too - if I deploy the same application to WebLogic 12.0.0.1, the application works and so I am sure this is something to do with WebLogic 10.3.4 and some versions of Jars that are bundled within WebLogic.

    Any ideas on thinks I can try here? Thanks in advance.

    --Vinny
Working...
X