Announcement Announcement Module
Collapse
No announcement yet.
Can't get there from here, or what do I do about spring-library-3.1.0.RELEASE.libd? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get there from here, or what do I do about spring-library-3.1.0.RELEASE.libd?

    When I don't have spring-library-3.1.0.RELEASE.libd' on my classpath I see the following error (Eclipse indigo)

    Project 'mvcProject' is missing required library: 'target/WEB-INF/lib/org.springframework.spring-library-3.1.0.RELEASE.libd'

    When I add the library to my lib directory I get the following error:

    Archive for required library: 'target/WEB-INF/lib/org.springframework.spring-library-3.1.0.RELEASE.libd' in project 'mvcProject' cannot be read or is not a valid ZIP file

    Could the library actually be unreadable or is something else going on?

    I'm stuck, any help or advice would be greatly appreciated.

    --bills

  • #2
    I found the problem and, as usual, it has nothing to do with Spring. I'm documenting it here in case someone else comes here with a similar issue.

    The basic problem was that I added spring-library.libd to my projects library list in Eclipse when I added all of the other jars that are delivered with the Spring distribution. From that point on Eclipse would issue the warning:

    Project 'mvcProject' is missing required library: 'target/WEB-INF/lib/org.springframework.spring-library-3.1.0.RELEASE.libd'

    if the file was not in the lib directory. If the file was there the other error message would be displayed:

    Archive for required library: 'target/WEB-INF/lib/org.springframework.spring-library-3.1.0.RELEASE.libd' in project 'mvcProject' cannot be read or is not a valid ZIP file

    So the lesson here is, *.libd files do not belong on the list of libraries for an Eclipse project.

    Comment

    Working...
    X