Announcement Announcement Module
Collapse
No announcement yet.
Help:Another Spring mvc 3+freemarker+sitemesh post.i messed up with sitemesh config Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help:Another Spring mvc 3+freemarker+sitemesh post.i messed up with sitemesh config

    I know a lot of people posted about this issue but i did read them all and am still unable to get sitemesh working on my machine.The key difference here is that i use 2 different view technologies.I've started working on a admin panel for an application but decision has change and i need to cater for public UI for the same applicaton, thus the need for another site templating+decorator.

    I've managed to get spring 3 mvc + freemarker 2.3.14 + zkoss 5.0.8 working side by side with 2 view resolvers i let spring controllers manage public UI views and ZK controllers manage admin section views.

    my codes are available on pastie

    my decorator layout layoutspring.html is in /WEB-INF/ui/templates and views are in /WEB-INF/ui/views

    the interesting part is that before sitemesh came into picture, when the webapp runs

    localhost:8080/my/
    returns the content of home.ftl => "it's working" and the admin also works fine.

    case 1

    <dispatcher>FORWARD</dispatcher>
    <!-- <dispatcher>REQUEST</dispatcher>-->
    the home.ftl meaning the text "it's working" shows but undecorated.When i type /admin/authentication/login is showing nothing.

    case 2

    <!--<dispatcher>FORWARD</dispatcher>-->
    <dispatcher>REQUEST</dispatcher>
    nothing shows at / but zk views at '/authentication/login' and /admin/** shows correctly

    case 3

    <!--<dispatcher>FORWARD</dispatcher>-->
    <!--<dispatcher>REQUEST</dispatcher>-->
    same as case 2

    case 4

    <dispatcher>FORWARD</dispatcher>
    <dispatcher>REQUEST</dispatcher>
    nothing shows at / and /admin but everything in zk views shows at /admin/** adn /authentication/login

    can anyone shed some light ? this is obviously configuration issues but right now i hit a block.Thanks for reading this
    Last edited by highjo; Jan 20th, 2012, 02:56 AM. Reason: title not captivating
Working...
X