Announcement Announcement Module
Collapse
No announcement yet.
Class nout found InternalResourceViewResolver in servlet-context.xml Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Class nout found InternalResourceViewResolver in servlet-context.xml

    Hi!

    I am getting a "Class" "not found" for InternalResourceViewResolver in servlet-context.xml in my STS IDE (eclipse) Problems view.

    As I recall, it's not a web mvc issue, but something else.

    I have seen this before and solved it the last time I downloaded a fresh new copy of the IDE and started things from scratch. However, I do not see the solution this time.


    Code:
    Class 'org.springframework.web.servlet.view.InternalResourceViewResolver' not found [config set: killbug/web-context]	servlet-context.xml	/killbug/src/main/webapp/WEB-INF/spring/appServlet	line 18	Spring Beans Problem
    Thanks in advance for your help!

    Mike

  • #2
    Hi,

    I am just setting up SpringSource MVC project in Eclipse IDE. I get the same error. Any pointers would be helpful.

    Comment


    • #3
      Hi buddies, I am seeing the same error with the fresh install of spring sts 2.8.1. Any ideas of what could be happening?

      Comment


      • #4
        Hi All,

        I also faced the same error. I actually figured out the problem and its solution. The problem is not with STS. The problem is with project configuration i.e build path. If you will right click and go to build path, you will notice that maven dependencies are missing and you will see red cross in maven dependencies. This means that newly created project is not having reference of all the required libs.

        To fix this simple do a maven clean and then maven install. It will download all the artifacts required for the project to build.After the build is successful just do a refresh,clean and build. This error will be gone. Hope this works for you

        Happy Learning !!

        Comment

        Working...
        X