Announcement Announcement Module
Collapse
No announcement yet.
Spring 3 compatibility Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring 3 compatibility

    What are the plans to release a version of Spring-WS that's fully compatible with Spring 3?

    Currently, there is the potential for classloading issues when using Spring-WS 1.5.7 with Spring 3 M3, for example clashes between the org.springframework.oxm package (which is part of Spring 3 and Spring-WS). I assume the next version of Spring-WS will require Spring 3, and will use the OXM stuff from that. Until that happens, using Spring-WS with Spring 3 is risky.

  • #2
    Why should it be dangerous? If you don't use the oxm stuff it isn't a problem, you shouldn't be using the big spring.jar but only the spring-[module].jars then simply leave out oxm....

    Comment


    • #3
      Yeah, but I *do* use the OXM stuff in Spring 3. Spring 3 and Spring-WS need to be 100% compatible, not "compatible as long as you don't use this bit".

      Comment

      Working...
      X