Announcement Announcement Module
Collapse
No announcement yet.
Can someone tell me what I'm missing? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can someone tell me what I'm missing?

    This is probably just a stupid newbie question, but I cannot seem to get a simple web service working at all. The MessageDispatcher servlet seems to just choke and die based on what I am sending it. This is the exception it is throwing:

    java.lang.IllegalArgumentException: local part cannot be "null" when creating a QName
    at javax.xml.namespace.QName.<init>(QName.java:214)
    at javax.xml.namespace.QName.<init>(QName.java:163)
    at org.apache.axis.message.PrefixedQName.<init>(Prefi xedQName.java:30)
    at org.apache.axis.message.MessageElement.getElementN ame(MessageElement.java:1504)
    at org.springframework.ws.soap.saaj.Saaj12Implementat ion.getName(Saaj12Implementation.java:70)


    This is the set up for the servlet in web.xml:

    <servlet>
    <servlet-name>test-ws</servlet-name>
    <servlet-class>org.springframework.ws.transport.http.Messag eDispatcherServlet</servlet-class>
    <init-param>
    <param-name>transformWsdlLocations</param-name>
    <param-value>true</param-value>
    </init-param>

    </servlet>
    <servlet-mapping>
    <servlet-name>test-ws</servlet-name>
    <url-pattern>/*</url-pattern>
    </servlet-mapping>



    This is what I am sending it:


    <?xml version="1.0" encoding="UTF-8"?>
    <UserInformationRequest xmlns="http://www.codemonkeyramblings.com/schemas/testservice">
    <Username>johnsmith</Username>
    <Password>50f457565bf5f04a665f85f86d0e0d9795062a9d </Password>
    </UserInformationRequest>


    I have tried pinging it both with a test client (based on the Echo sample) and SoapUI. In both cases it dies with the same error message.

    Any suggestions about what I am doing wrong?

    The only thing that I could find was this suggestion: http://forum.springsource.org/showthread.php?t=42620

    It seems that having the Axis2 jars on the classpath caused the problem for some people, but when I removed the Axis2 jars, the web services threw a number of exceptions from that.
Working...
X