Announcement Announcement Module
Collapse
No announcement yet.
XwsSecurityInterceptor problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • XwsSecurityInterceptor problem

    Hi all
    I'm trying to use the XwsSecurityInterceptor but I get several errors during compilation.
    I'm using Maven to solve dependencies but this time it doesn't help.
    The first error is a missing reference to com.sun.xml.wss.
    After solving it (found it around the web and uploaded to our internal nexus server) I get some other similar error, ie other packages missing (com.sun.org.apache.xml.security and javax.xml.crypto),
    I've tried to solve following a post that said to use also the Spring repository, but it doesn't work (Maven says it's not a valid repository).

    Is there anybody who can help me?

    Thx,
    Zak

  • #2
    Solved.
    I write here the solution because it may help other people.
    I downloaded all the jars and pom files from the Spring repo and then installed in our private Nexus server.
    Now it works fine.
    Take care not to use xws-security-3.0 but xws-security-2.0-ea (the artifact you will find in Spring repo)

    Bye
    Zak

    Comment

    Working...
    X