Announcement Announcement Module
Collapse
No announcement yet.
WebSphere issue, possibly with annotation-based SOAP endpoints Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • WebSphere issue, possibly with annotation-based SOAP endpoints

    Hi

    I'm using spring-ws 1.5.7, and wiring up my SOAP endpoints using annotations. This is all working fine on Tomcat.

    When I try to run on Websphere (and I have wired up the class loader to run "application first"/"parent last") my bean initialization phase fails, with the root cause exception being:

    Code:
    Caused by: java.lang.NullPointerException
    	at org.springframework.ws.soap.addressing.server.AnnotationActionEndpointMapping.postProcessAfterInitialization(AnnotationActionEndpointMapping.java:143)
    	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyBeanPostProcessorsAfterInitialization(AbstractAutowireCapableBeanFactory.java:361)
    	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.postProcessObjectFromFactoryBean(AbstractAutowireCapableBeanFactory.java:1429)
    	at org.springframework.beans.factory.support.FactoryBeanRegistrySupport$1.run(FactoryBeanRegistrySupport.java:139)
    It looks like the culprit is something to do with AnnotationActionEndpointMapping, but there's very little to go on in the stack trace, or in the source for AnnotationActionEndpointMapping.java.

    My best guess is that something is going wrong with AOP in the WebSphere environment, but I can't find a reference to any similar problems elsewhere.

    If anyone has any suggestions I'd be most grateful, before I redo the wiring to avoid the use of annotations
Working...
X