Announcement Announcement Module
Collapse
No announcement yet.
Which jaxb versions to use with Java 5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Which jaxb versions to use with Java 5

    I am attempting to build a simple standalone web client using the WebServiceTemplate with JAXB marshalling using a Java 5 JRE and building with maven. I had this running without problems with a Java 6 JRE but am having problems resolving the necessary javax.xml jars needed for the Java 5 environment.

    My maven javax.xml direct dependencies in my local pom are:

    javax.xml:jaxb-api:2.0EA3
    javax.xml:jaxb-impl:2.0EA3 [runtime]
    javax.xml:jsr173:1.0 [runtime]
    javax.xml.soap:saaj-impl:1.3 [runtime]

    As best I can tell, the 2.0EA3 jar is an early access version which apparently contains classes that were subsequently renamed. In particular, using maven-jaxb-2-plugin:0.7.0 to generate code from my XSD I end up with code referencing a class javax.xml.bind.annotation.XmlAccessType which does not exist in my jaxb-api jar (AccessType does).

    What are the right version numbers (artifacts/repositories) required to use JAXB outside of a container with a Java 5 runtime?

  • #2
    hi,
    try using version 2.1.9.

    Comment


    • #3
      Originally posted by shadowLaw View Post
      hi,
      try using version 2.1.9.
      Thanks, I downloaded 2.1.9 off of the Glassfish site and manually installed the api and impl JAXB jars in my local respository and that seems to work. Is there a repository that contains this version or is manual installation the only way to go?

      Comment

      Working...
      X