Announcement Announcement Module
Collapse
No announcement yet.
Again problem with C# Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Again problem with C#

    Hello everybody,

    we are also having troubles with calling our (spring-ws based) WebService from a C# client.

    The C# Client is sending us:
    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
    <s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <MyRequestObj paramA="0" paramB="123" xmlns="http://movilitas.com/movilizer">
    ....
    </MyRequestObj>
    </s:Body>
    </s:Envelope>

    but Spring-WS expects something like this:
    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" xmlns:m="http://movilitas.com/movilizer">
    <s:Body>
    <m:MyRequestObj paramA="0" paramB="123">
    ....
    </m:MyRequestObj>
    </s:Body>
    </s:Envelope>


    The Request sent by C# is rejected with a SOAP evelope error :-(
    1. Is this correct what the C# client does - Does it confirm to the standard?
    2. How can we make it work? Best would be if we could make spring to allow such requests, but if changing something on the C# client makes it possible, thats also fine.

    Thanks for any help,
    Christian

  • #2
    Nobody here likes to use .net? :-)

    Comment


    • #3
      Have you considered trying a different client? We use SoapUI which can be used quite nicely to test a web service, e.g. it can validate the request if it is conform to a xml scheme.

      Just my 2 cents ...

      Comment


      • #4
        Hi Robert,

        I'm also using SOAPUI for testing purposes, very nice tool for that :-)

        The problem is that one of our customers would like to integrate our WebService, and (unfortunetaly) they are using .net...

        I found out that adding the following to my pom is supposed to solve the problem:
        Code:
        		<dependency>
        			<groupId>xerces</groupId>
        			<artifactId>xercesImpl</artifactId>
        			<version>2.9.1</version>
        		</dependency>
        
        		<dependency>
        			<groupId>xalan</groupId>
        			<artifactId>xalan</artifactId>
        			<version>2.7.1</version>
        		</dependency>
        Unfortunetaly the other guys havn't had the time to rerun the .net WebService client. So I can't really tell yet whether it works now or not....

        regards,
        Christian
        Last edited by horschi; Feb 6th, 2009, 07:30 AM. Reason: typo

        Comment


        • #5
          Hi Christian,

          just curious ... why are you needing these dependencies? This is not a Java 1.4 thing is it?
          (If so, be sure to read the FAQ of Spring-WS and your web container documentation on how they deal with the endorsed libs)

          Cheers,

          Robert

          Comment


          • #6
            Ok, adding xercesImpl and xalan solved the problem.

            Robert: I dont know why, I just read it and it works.

            Comment

            Working...
            X