Announcement Announcement Module
Collapse
No announcement yet.
Strange behaviour of Spring WS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange behaviour of Spring WS

    Hello all,


    I just started a new project that will expose WSs by using the Spring WS
    framework. I tried another time to use this framework and every went well,
    but now I have some problems:

    1. I used the sample Echo project - when deploying it everything went well
    when I tried to add the same configurations in another project, that was different only by his name I couldn't access the wsdl from Firefox browser.
    I solved that problem by using another url; but... when I try testing this service
    from soapUI I encounter another problem :

    <html><head><title>Apache Tomcat/5.5.25 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - /message/services</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>/message/services</u></p><p><b>description</b> <u>The requested resource (/message/services) is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/5.5.25</h3></body></html>


    2. I tried adding another another service and the same problem...from the browser it all works fine, but when trying to test it with soapUI it crashes
    with the above error message.

    I uploaded the configuration file for the dispatcher servlet and the web.xml configuration file.

  • #2
    You have to make sure that the mapping (to /message/services) exists in your web.xml, and that the incoming messages are understood by the endpoint mapping. If you provide your servers-side log, that could help us some more.

    Comment

    Working...
    X