Announcement Announcement Module
Collapse
No announcement yet.
Wss4jSecurityInterceptor Problem with Java 1.4 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wss4jSecurityInterceptor Problem with Java 1.4

    Hi All,

    I'm using Java 1.4.2 and building a web service with Spring. I am attempting to build out the security interceptor using Wss4jSecurityInterceptor. I am getting a java.lang.NoClassDefFoundError: java/security/KeyStore$ProtectionParameter error when trying to set my validation and securement properties. The problem comes up when trying to inject the Wss4jSecurityInterceptor into the endpoint.

    KeyStore$ProtectionParameter does not exist with Java 1.4. I am wondering if using Spring WS 1.5 with Java 1.4 is possible and if there is a way around this problem.

    Any and all help would be appreciated.

    Thank you.

  • #2
    Could you post the full stack trace please?

    Comment


    • #3
      http://jira.springframework.org/browse/SWS-307

      Comment


      • #4
        This will be fixed in the next release. Just to be clear: Spring-WS 1.5 will still support JDK 1.4.

        Comment


        • #5
          The patch listed in the ticket resolved the issue. Thanks for the quick turnaround time, Tareq.

          Comment

          Working...
          X