Announcement Announcement Module
No announcement yet.
WebServcTemplate produces non-correct result XML from valid response Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • WebServcTemplate produces non-correct result XML from valid response


    I execute web service request via
    webServiceTemplate.sendSourceAndReceiveToResult(so urce, result);
    , and I got proper SOAP response looking at the log from "" logger.

    But when I fetch this response XML from my Result instance, it returns me some other, non-correct XML. I thought it was maybe bug with JDOMesult that I used, so I tried with plan StringResult and I got same XML.

    Here is SOAP body part received and logged by

    <ns1:getSmsDeliveryStatusResponse soapenv:encodingStyle="" xmlns:ns1="">
    			<result soapenc:arrayType="ns1:DeliveryStatusType[1]" xsi:type="soapenc:Array" xmlns:soapenc="">
    				<result href="#id0"/>
    		<multiRef id="id0" soapenc:root="0" soapenv:encodingStyle="" xsi:type="ns2:DeliveryStatusType" xmlns:soapenc="" xmlns:ns2="">
    			<destinationAddress href="#id1"/>
    			<deliveryStatus href="#id2"/>
    		<multiRef id="id1" soapenc:root="0" soapenv:encodingStyle="" xsi:type="ns3:EndUserIdentifier" xmlns:ns3="" xmlns:soapenc="">
    			<value xsi:type="xsd:anyURI">tel:385912392624</value></multiRef>
    		<multiRef id="id2" soapenc:root="0" soapenv:encodingStyle="" xsi:type="ns4:DeliveryStatus" xmlns:ns4="" xmlns:soapenc="">
    And here is the one obtained from Result instance:

    <ns1:getSmsDeliveryStatusResponse xmlns:ns1="" xmlns:soapenv="" soapenv:encodingStyle="">
    	<result xmlns:soapenc="" soapenc:arrayType="ns1:DeliveryStatusType[1]" xmlns:xsi="" xsi:type="soapenc:Array">
    		<result href="#id0"/>
    Thoughts ?


  • #2
    Arjen always talked how bad and deprecated (in SOAP 1.2) are rpc/encoding WSDLs, and my SOAP traffic examples are exactly from this kind of web service.
    Can it be that because of this "unsupporting" reason I don't receive complete payload in my Result instances?

    BTW. I tried with both 1.0.3 and 1.5m1