Announcement Announcement Module
Collapse
No announcement yet.
SpringWS Tutorial Setup Step not working... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpringWS Tutorial Setup Step not working...

    Hi,

    I tried to follow the maven instruction that you mentioned in the tutorial to create the project for the tutorial sample using the following command:

    ~/java/maven-2.0.4/bin/mvn archetype:create -DarchetypeGroupId=org.springframework.ws -DarchetypeArtifactId=spring-ws-archetype -DarchetypeVersion=1.0-m4-SNAPSHOT -DgroupId=com.mycompany.hr -DartifactId=holidayService

    =====================Output I get is==============
    [INFO] Scanning for projects...
    [INFO] Searching repository for plugin with prefix: 'archetype'.
    [INFO] ----------------------------------------------------------------------------
    [INFO] Building Maven Default Project

    ...

    [INFO] Velocimacro : initialization complete.
    [INFO] Velocity successfully started.
    [INFO] [archetype:create]
    [INFO] Defaulting package to group ID: com.mycompany.hr
    [INFO] ------------------------------------------------------------------------
    [ERROR] BUILD ERROR
    [INFO] ------------------------------------------------------------------------
    [INFO] Failed to resolve artifact.

    GroupId: org.springframework.ws
    ArtifactId: spring-ws-archetype
    Version: 1.0-m4-SNAPSHOT

    Reason: Unable to download the artifact from any repository

    Try downloading the file manually from the project website.

    Then, install it using the command:
    mvn install:install-file -DgroupId=org.springframework.ws -DartifactId=spring-ws-archetype \
    -Dversion=1.0-m4-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file


    org.springframework.ws:spring-ws-archetype:jar:1.0-m4-SNAPSHOT

    from the specified remote repositories:
    central (http://repo1.maven.org/maven2)


    [INFO] ------------------------------------------------------------------------
    [INFO] For more information, run Maven with the -e switch
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 1 second
    [INFO] Finished at: Mon Apr 02 22:42:43 PDT 2007
    [INFO] Final Memory: 4M/8M
    [INFO] ------------------------------------------------------------------------

    I have very little experience with Maven. Let me know how can I fix this.

    Thanks

  • #2
    A solution is described in http://forum.spring.io/node/27860.

    Comment

    Working...
    X