Announcement Announcement Module
Collapse
No announcement yet.
Invalid WSDL being generated Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid WSDL being generated

    I am getting invalid WSDL generated by either the org.springframework.ws.transport.http.WsdlDefiniti onHandlerAdapter or the org.springframework.ws.wsdl.wsdl11.SimpleWsdl11Def inition classes. The problem is that one of my namespace definitions is lost. Notice that the "tns:" namespace is lost in the following WSDL fragments:

    Original WSDL:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <wsdl:definitions xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:tns="urn:BxBenefits/1.0" xmlns:xsd="http://www.w3.org/2001/XMLSchema" name="BxBenefits" targetNamespace="urn:BxBenefits/1.0">
    	<wsdl:documentation/>
    	<wsdl:types>
    		<xsd:schema>
    			<xsd:import namespace="urn:BxBenefits/1.0" schemaLocation="BxBenefits.xsd"/>
    		</xsd:schema>
    	</wsdl:types>
    	<wsdl:message name="FindGroupProductsRequest">
    		<wsdl:part element="tns:FindGroupProducts" name="parameters"/>
    	</wsdl:message>
    	<wsdl:message name="FindGroupProductsResponse">
    		<wsdl:part element="tns:FindGroupProductsResponse" name="parameters"/>
    	</wsdl:message>
    Transformed WSDL:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <wsdl:definitions xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" name="BxBenefits" targetNamespace="urn:BxBenefits/1.0">
    	<wsdl:documentation/>
    	<wsdl:types>
    		<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    			<xsd:import namespace="urn:BxBenefits/1.0" schemaLocation="BxBenefits.xsd"/>
    		</xsd:schema>
    	</wsdl:types>
    	<wsdl:message name="FindGroupProductsRequest">
    		<wsdl:part element="tns:FindGroupProducts" name="parameters"/>
    	</wsdl:message>
    	<wsdl:message name="FindGroupProductsResponse">
    		<wsdl:part element="tns:FindGroupProductsResponse" name="parameters"/>
    	</wsdl:message>
    Since the "tns:" namespace definition is lost, the following references become invalid:
    Code:
    element="tns:FindGroupProducts"
    I found this problem when I attempted to load the WSDL into SoapUI via the URL. SoapUI loaded the file correctly, but the URL load failed.

    Shannon Kendrick

  • #2
    Now that's weird, because the SimpleWsdlDefinition doesn't do anything with the WSDL but read it. So I guess it must be in the adapter.

    Could you please post a JIRA issue for this? With the two WSDLs as attachments, if possible?

    Thanks

    Comment

    Working...
    X