Announcement Announcement Module
Collapse
No announcement yet.
Wsdl definition builder problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wsdl definition builder problems

    Hi all,

    I am having an issue using the XsdBasedSoap11Wsdl4jDefinitionBuilder class to dynamically build my wsdl file; my xsd file is quite complicated and not all xs:element tags have a 'name' attribute (for example I have some tags like xs:element ref='' that reference definitions in other parts of my file). This is causing the builder to fail with the following exception when requesting the wsdl:

    java.lang.NullPointerException
    at org.springframework.ws.wsdl.wsdl11.builder.XsdBase dSoap11Wsdl4jDefinitionBuilder.isRequestMessage(Xs dBasedSoap11Wsdl4jDefinitionBuilder.java:244)
    at org.springframework.ws.wsdl.wsdl11.builder.XsdBase dSoap11Wsdl4jDefinitionBuilder.buildMessages(XsdBa sedSoap11Wsdl4jDefinitionBuilder.java:223)
    at org.springframework.ws.wsdl.wsdl11.builder.Abstrac tWsdl4jDefinitionBuilder.buildMessages(AbstractWsd l4jDefinitionBuilder.java:115)
    <rest removed>

    I can see from the source that the method buildMessages expects each element to have a name attribute. On this evidence, is the XsdBasedSoap11Wsdl4jDefinitionBuilder only suited for simple xsd files or have I uncovered a defect?

    Has anyone else had similar issues?

    thanks,

    Paul.

  • #2
    I could change the code so that it only makes messages out of elements with names (i.e. do a null check at XsdBasedSoap11Wsdl4jDefinitionBuilder, line 233). Could you create a JIRA issue for this?

    Thanks for spotting this!

    Comment


    • #3
      Facing the same problem, is there a issue/bug number yet?

      I'm facing the same problem. I have schema with <element ref="..."> tags and causing the NullPointerException in XsdBasedSoap11Wsdl4jDefinitionBuilder.

      Do we have a bug or issue number logged in Jira yet? If yes, please let me know so that I can watch for it once it is fixed.
      If not please let me know I will be more than happy to file one.

      Thanks

      Comment


      • #4
        There's no issue yet...

        Comment


        • #5
          Jira

          Sorry guys,

          Been busy...Here is the JIRA:
          http://opensource.atlassian.com/proj...browse/SWS-101

          I have also tested and uploaded the patched class (as suggested by Arjen).

          regards,

          Paul.

          Comment


          • #6
            ...issue is fixed in SVN.

            Comment


            • #7
              Thnx for fixing it quick. Should I update 1.0m3?

              Thanks Arjen to fix the problem so quick.
              How will I get the updated code. Should I just download the "1.0m3 download" from Spring WS website or do I have to wait for next milestone build or do I have to build Spring WS locally based on the latest 1.0m3 source.

              Comment


              • #8
                You can download a snapshot release here: http://static.springframework.org/sp...snapshots.html

                Comment

                Working...
                X