Announcement Announcement Module
Collapse
No announcement yet.
Problem using Axis2 (1.1) and Spring-WS (1.0 m2) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem using Axis2 (1.1) and Spring-WS (1.0 m2)

    Hi

    Trying to use Axis2 and Spring-WS specifically the axiom framework, endpoint dispatching and xmlbeans databinding.

    Running into some version issues -
    Axis2(1.1) uses axiom 1.2 and Spring-WS (1.0 m2) uses axiom 1.0.

    Any work arounds or suggestions?
    Any plans to promote Spring-WS to use axiom 1.2?

    Getting this following error message -
    Caused by: java.lang.NoClassDefFoundError: org/apache/axiom/om/impl/mtom/MTOMStAXSOAPModelBuilder
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:260)
    at org.springframework.util.ClassUtils.forName(ClassU tils.java:109)
    at org.springframework.beans.factory.support.BeanDefi nitionReaderUtils.createBeanDefinition(BeanDefinit ionReaderUtils.java:65)
    at org.springframework.beans.factory.xml.DefaultXmlBe anDefinitionParser.parseBeanDefinitionElement(Defa ultXmlBeanDefinitionParser.java:466)
    .......

    Thx
    Jacob

  • #2
    Yes, Axiom 1.2 changed some things. Luckily, it also fixed some bugs I reported.

    Support for Axiom 1.2 is in subversion right now, and will be part of the 1.0 M3 release due soon.

    Comment

    Working...
    X