Announcement Announcement Module
No announcement yet.
Spring WS depenencies on versions of Spring and Acegi Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring WS depenencies on versions of Spring and Acegi


    I'm very much interested in pursuing use of Spring WS. I'm trying to determine just what versions of both Spring and Acegi Security will work with Spring WS (1.0 M2).

    I downloaded the full zip file, and can see in lib acegi-security-1.0.1.jar, and spring-*-1.2.8.jar. I guess that answers the question re: Acegi, but will Spring WS work with Spring 1.2.1? Is there something is just must have in 1.2.8? Does it work with Spring 2.0?

    My current app is a bit behind the times, using Spring 1.2.1 and Acegi 0.8.3. I obviously need to go through the pain of migrating to Acegi 1.0, but will Spring 1.2.1 suffice? Or, if I go through going all the way to Spring 2.0, with Spring WS have a problem with that?

    The plan is to move to J2SE 5 (Tomcat 5) from 1.4. But if I don't do that, is there any problem using Spring WS?

    Many thanks!

    Last edited by jas; Nov 13th, 2006, 08:42 PM.

  • #2
    I don't know about Acegi, but I think it should work with Spring 1.2.1. That said, you should really try to upgrade to 1.2.8 (or the upcoming 1.2.9), because it contains essential bug fixes. It should just be a drop-in replacement.

    With regard to Spring 2.0: Spring-WS does not require it, but it will be required for some features in the future.

    And finally: J2SE 5 is not required, just for the oxm-tiger module.



    • #3

      Thanks a lot for the great information. I read through your Spring WS tutorial and in the Authentication section there are some examples of hooking into Acegi. For example, AcegiPlainTextPasswordValidationCallbackHandler has an authenticationManager property. Shown is using a reference to org.acegisecurity.providers.ProviderManager.

      As far as I can tell looking at the Acegi docs is that the org.acegisecurity.* naming convention pertains to the 1.0 version vs. net.sf.acegisecurity.* for prior versions. So I assume that Spring-WS requires 1.0.

      I'll try dropping in Spring 1.2.8 as well.