Announcement Announcement Module
Collapse
No announcement yet.
could not find deserializer for type ... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • could not find deserializer for type ...

    I have a C# web service that i would like to connect to and run an operation and get the results back using java and the spring web services stuff.

    The following is the result definition in the wsdl for the C# web service:
    <s:complexType>
    <s:sequence>
    <s:element ref="s:schema" />
    <s:any />
    </s:sequence>
    </s:complexType>

    I get the following error when i run:
    org.xml.sax.SAXException: Deserializing parameter 'theElementName': could not find deserializer for type {namespaceUri}>>TheResult>theElementName

    It seems like the problem is the results returned....

    All i have done on the client side is create an interface for the service that defines this one operation with the given parameters in the wsdl and configured the clientContext.xml.

    Do i need to do something extra?
    What should the return type be for the service interface?

  • #2
    Did you find a solution ?

    I encountered the same problem.
    Did you find any solution ???

    Comment


    • #3
      No

      No i havent. I have posted on some other forums as well with no luck there either. Let me know if you find out anything.

      Comment


      • #4
        It works

        Hoping it can help you, I found a solution. I have generated all classes with wsdl2java standard command without deleting any classes and it works. Last time, I used the method described here http://cse-mjmcl.cse.bris.ac.uk/blog...165512463.html but it doesn't work, perhaps because of deleting specific axis code ???

        Comment


        • #5
          Yes that did help

          Yes your suggestion did help and relieved me of that error.
          I honestly cant explain why that fixed it but maybe you could?

          FIX:
          the only thing i did to fix my problem is use the Axis wsdl2java to create some .java files. One of which is was a interface that represented the method call of the webservice. I replaced my previous interface with the new one in the clientApplication.xml spring config file (the serviceInterface property). Re-ran and it works.

          Thank you again!!!

          Comment

          Working...
          X