Announcement Announcement Module
Collapse
No announcement yet.
more than one schema in PayloadValidatingInterceptor Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The schema handling code Spring-WS's PayloadValidatingInterceptor depends on javax.xml.validation.Schema. The algorithm for multiple namespaces is described here: http://java.sun.com/j2se/1.5.0/docs/...ansform.Source[]), the "W3C XML Schema 1.0" part of that method specifically.

    Comment


    • #17
      I ran into this problem too when using the PayloadValidatingInterceptor to validate against multiple schemas that were all in the same namespace. Due to what looks to be a vagueness in the spec or the JAXP implementation, there is some flakiness when validating multiple schemas with the same namespace.

      For what it is worth, I was able to get past my problems by pointing my validating interceptor to a single xsd file that included all my schemas, and by avoiding using relative paths that used "../". This works fine now. I think the weirdness is in JAXP, not spring-ws.

      BTW - Afterwards I found this link where someone else encountered basically the exact same problems I did. See: http://kontrawize.blogs.com/kontrawi...rouble-wit.htm

      Comment


      • #18
        Originally posted by jimcummings View Post
        I ran into this problem too when using the PayloadValidatingInterceptor to validate against multiple schemas that were all in the same namespace. Due to what looks to be a vagueness in the spec or the JAXP implementation, there is some flakiness when validating multiple schemas with the same namespace.

        For what it is worth, I was able to get past my problems by pointing my validating interceptor to a single xsd file that included all my schemas, and by avoiding using relative paths that used "../". This works fine now. I think the weirdness is in JAXP, not spring-ws.

        BTW - Afterwards I found this link where someone else encountered basically the exact same problems I did. See: http://kontrawize.blogs.com/kontrawi...rouble-wit.htm
        Fixing the link in my post: http://kontrawize.blogs.com/kontrawi...ouble-wit.html

        Comment

        Working...
        X