Announcement Announcement Module
Collapse
No announcement yet.
Does Websphere 7 have the same issues as websphere 6 ? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Does Websphere 7 have the same issues as websphere 6 ?

    I'm getting the following error when deploying a client webservice to websphere 7 :

    JAX-WS Service Descriptions could not be correctly built because of the following error: javax.xml.ws.WebServiceException: Validation error: This is a Provider that does not specify a valid Provider interface. Implementation class: com.sun.xml.ws.mex.server.MEXEndpoint

    I saw that the resolution on WAS 6 was to change the classloading to parent last. This didnt have the desired effect. Does anyone have spring ws successfully deployed in WAS 7 ??

    thanks

  • #2
    There are two places in the websphere admin console to change the class loader to be parent last (well there is in 8.5 so am guessing there will be in 7) - have you done both?

    1) In 8.5 you need to go All Applications -> Application Name -> Manage Modules then click on the application name (under the module heading) in the table. This will bring up a further configuration screen where you can specify in the drop down the class loader order.

    2) The other place for this is All Applications -> Application Name -> Class loading and update detection

    Not sure if both are required but it didn't work for us without the one we did for 1) so have taken the safety first approach and did it in both places.

    Cheers

    Comment

    Working...
    X