Announcement Announcement Module
Collapse
No announcement yet.
Simple HolidayService Tutorial - Error : No adapter for endpoint - Why ? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Simple HolidayService Tutorial - Error : No adapter for endpoint - Why ?

    I was following the tutorial below exactly (except the package name changed to nk.spring for all classes).

    ref: http://static.springsource.org/sprin.../tutorial.html


    I deploy the app to local web server (vmware vFabric - I'm using STS).

    when I use SOAP UI to test the web service, I got below error:

    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
    <SOAP-ENV:Header/>
    <SOAP-ENV:Body>
    <SOAP-ENV:Fault>
    <faultcode>SOAP-ENV:Server</faultcode>
    <faultstring xml:lang="en">No adapter for endpoint [public void nk.spring.HolidayEndpoint.handleHolidayRequest(org .jdom.Element) throws java.lang.Exception]: Is your endpoint annotated with @Endpoint, or does it implement a supported interface like MessageHandler or PayloadEndpoint?</faultstring>
    </SOAP-ENV:Fault>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>


    I tried to double check the steps and searched through the internet for help but no avail.
    It seems no easy to configure - even simple tutorial I couldnt get it working.

    Can you help ?


    My spring-ws-servlet.html

    <?xml version="1.0" encoding="UTF-8"?>
    <beans xmlns="http://www.springframework.org/schema/beans"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:context="http://www.springframework.org/schema/context"
    xmlns:sws="http://www.springframework.org/schema/web-services"
    xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schem...-beans-3.0.xsd
    http://www.springframework.org/schema/web-services http://www.springframework.org/schem...rvices-2.0.xsd
    http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-3.0.xsd">

    <context:component-scan base-package="nk.spring"/>
    <sws:annotation-driven/>
    <!-- <sws:static-wsdl id="holiday" location="/WEB-INF/holiday.wsdl"/> -->

    <bean id="holiday" class="org.springframework.ws.wsdl.wsdl11.SimpleWs dl11Definition">
    <property name="wsdl" value="WEB-INF/holiday.wsdl"/>
    </bean>
    <bean id="hr" class="org.springframework.xml.xsd.SimpleXsdSchema ">
    <property name="xsd" value="/WEB-INF/hr.xsd" />
    </bean>

    </beans>

  • #2
    Have you find a solution to your issue ?
    I have exactly the same problem !

    Comment

    Working...
    X