Announcement Announcement Module
Collapse
No announcement yet.
The method setHttpClient(HttpClient) from the type CommonsHttpMessageSender refers to Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • The method setHttpClient(HttpClient) from the type CommonsHttpMessageSender refers to

    I use spring web service 2.1.2 in my project,the following code:
    Code:
    HttpClient httpClient = new DefaultHttpClient();
    		CommonsHttpMessageSender httpMessageSender = new CommonsHttpMessageSender();
    		httpMessageSender.setHttpClient(httpClient);
    tell me
    The type org.apache.commons.httpclient.HttpClient cannot be resolved. It is indirectly referenced from required .class files
    my pom.xml config:
    Code:
    <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    	xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
    	<modelVersion>4.0.0</modelVersion>
    	<groupId>com.janwen.maven</groupId>
    	<artifactId>FutureMaven</artifactId>
    	<packaging>war</packaging>
    	<version>1.0-SNAPSHOT</version>
    	<name>Future Maven Webapp</name>
    	<url>https://dreamandfuture.googlecode.com/svn/trunk/FutureMaven</url>
    
    	<!-- Shared version number properties -->
    	<properties>
    		<org.springframework.version>3.2.1.RELEASE</org.springframework.version>
    	</properties>
    
         <dependencies>
    
    		<!-- spring relative -->
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-context</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-jdbc</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-web</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    		<!-- Various Application Context utilities, including EhCache, JavaMail, 
    			Quartz, and Freemarker integration Define this if you need any of these integrations -->
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-context-support</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    		<!-- Bean Factory and JavaBeans utilities (depends on spring-core) Define 
    			this if you use Spring Bean APIs (org.springframework.beans.*) -->
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-beans</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    <dependency>
    	<groupId>org.springframework.ws</groupId>
    	<artifactId>spring-ws-support</artifactId>
    	<version>2.1.2.RELEASE</version>
    </dependency>
    <dependency>
    	<groupId>org.springframework.ws</groupId>
    	<artifactId>spring-xml</artifactId>
    	<version>2.1.2.RELEASE</version>
    </dependency>
    <dependency>
    	<groupId>org.springframework.ws</groupId>
    	<artifactId>spring-ws-security</artifactId>
    	<version>2.1.2.RELEASE</version>
    </dependency>
                            
                
    
    		<!-- Object-to-XML Mapping (OXM) abstraction and integration with JAXB, 
    			JiBX, Castor, XStream, and XML Beans. (depends on spring-core, spring-beans, 
    			spring-context) Define this if you need OXM (org.springframework.oxm.*) -->
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-oxm</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-aop</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-webmvc</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework</groupId>
    			<artifactId>spring-test</artifactId>
    			<version>${org.springframework.version}</version>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework.ws</groupId>
    			<artifactId>spring-ws-core</artifactId>
    			<version>2.1.2.RELEASE</version>
    		</dependency>
    		<dependency>
    			<groupId>org.aspectj</groupId>
    			<artifactId>aspectjweaver</artifactId>
    			<version>1.7.0</version>
    		</dependency>
    
    		<dependency>
    			<groupId>cglib</groupId>
    			<artifactId>cglib</artifactId>
    			<version>2.2.2</version>
    		</dependency>
    
    	<!-- log relative -->
    		<dependency>
    			<groupId>commons-logging</groupId>
    			<artifactId>commons-logging-api</artifactId>
    			<version>1.1</version>
    		</dependency>
    		<dependency>
    			<groupId>log4j</groupId>
    			<artifactId>log4j</artifactId>
    			<version>1.2.17</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.slf4j</groupId>
    			<artifactId>slf4j-log4j12</artifactId>
    			<version>1.6.4</version>
    		</dependency>
    
    		<dependency>
    			<groupId>ebay.api.sdk</groupId>
    			<artifactId>attributes</artifactId>
    			<version>805</version>
    		</dependency>
    
    
    		<!-- ebay api exteral lib -->
    		<dependency>
    			<groupId>javax.activation</groupId>
    			<artifactId>activation</artifactId>
    			<version>1.1.1</version>
    		</dependency>
    		<dependency>
    			<groupId>com.sun.xml.fastinfoset</groupId>
    			<artifactId>FastInfoset</artifactId>
    			<version>1.2.12</version>
    		</dependency>
    
    		<dependency>
    			<groupId>com.sun.net.httpserver</groupId>
    			<artifactId>http</artifactId>
    			<version>20070405</version>
    		</dependency>
    
    		<dependency>
    			<groupId>apache-oro</groupId>
    			<artifactId>jakarta-oro</artifactId>
    			<version>2.0.8</version>
    		</dependency>
    		<dependency>
    			<groupId>javax.xml.bind</groupId>
    			<artifactId>jaxb-api</artifactId>
    			<version>2.2.7</version>
    		</dependency>
    		<dependency>
    			<groupId>com.sun.xml.bind</groupId>
    			<artifactId>jaxb-impl</artifactId>
    			<version>2.2.6</version>
    		</dependency>
    		<dependency>
    			<groupId>com.sun.xml.bind</groupId>
    			<artifactId>jaxb-xjc</artifactId>
    			<version>2.2.6</version>
    		</dependency>
    		<dependency>
    			<groupId>javax.xml.ws</groupId>
    			<artifactId>jaxws-api</artifactId>
    			<version>2.2.8</version>
    		</dependency>
    
    		<dependency>
    			<groupId>com.sun.xml.ws</groupId>
    			<artifactId>jaxws-rt</artifactId>
    			<version>2.2.7</version>
    		</dependency>
    		<dependency>
    			<groupId>com.sun.xml.ws</groupId>
    			<artifactId>jaxws-tools</artifactId>
    			<version>2.2.7</version>
    		</dependency>
    		<dependency>
    			<groupId>javax.xml.bind</groupId>
    			<artifactId>jsr173_api</artifactId>
    			<version>1.0</version>
    		</dependency>
    		<dependency>
    			<groupId>javax.jws</groupId>
    			<artifactId>jsr181-api</artifactId>
    			<version>1.0-MR1</version>
    		</dependency>
    		<dependency>
    			<groupId>javax.annotation</groupId>
    			<artifactId>jsr250-api</artifactId>
    			<version>1.0</version>
    		</dependency>
    		<dependency>
    			<groupId>org.jvnet</groupId>
    			<artifactId>mimepull</artifactId>
    			<version>1.6</version>
    		</dependency>
    		<dependency>
    			<groupId>com.sun.org.apache.xml.internal</groupId>
    			<artifactId>resolver</artifactId>
    			<version>20050927</version>
    		</dependency>
    		<dependency>
    			<groupId>javax.xml.soap</groupId>
    			<artifactId>saaj-api</artifactId>
    			<version>1.3.4</version>
    		</dependency>
    		<dependency>
    			<groupId>javax.xml.soap</groupId>
    			<artifactId>saaj-impl</artifactId>
    			<version>1.3</version>
    		</dependency>
    		<dependency>
    			<groupId>xalan</groupId>
    			<artifactId>serializer</artifactId>
    			<version>2.7.1</version>
    		</dependency>
    		<dependency>
    			<groupId>com.sun.xml.stream</groupId>
    			<artifactId>sjsxp</artifactId>
    			<version>1.0.2</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.jvnet.staxex</groupId>
    			<artifactId>stax-ex</artifactId>
    			<version>1.7.1</version>
    		</dependency>
    		<dependency>
    			<groupId>com.sun.xml.stream.buffer</groupId>
    			<artifactId>streambuffer</artifactId>
    			<version>1.5.1</version>
    		</dependency>
    		<dependency>
    			<groupId>xalan</groupId>
    			<artifactId>xalan</artifactId>
    			<version>2.7.1</version>
    		</dependency>
    
    
    
    
    
    
    
    
    		<!-- test relative junit and so on -->
    		<dependency>
    			<groupId>junit</groupId>
    			<artifactId>junit</artifactId>
    			<version>4.10</version>
    		</dependency>
    
    		<dependency>
    			<groupId>org.slf4j</groupId>
    			<artifactId>slf4j-api</artifactId>
    			<version>1.6.4</version>
    		</dependency>
    
    		<!-- http client -->
    		<dependency>
    			<groupId>org.apache.httpcomponents</groupId>
    			<artifactId>httpclient</artifactId>
    			<version>4.2.3</version>
    		</dependency>
    		<dependency>
    			<groupId>org.apache.httpcomponents</groupId>
    			<artifactId>httpcore</artifactId>
    			<version>4.2.3</version>
    		</dependency>
    
    
    
    
    		<!-- jsp servlet -->
    
    		<dependency>
    			<groupId>javax.servlet</groupId>
    			<artifactId>servlet-api</artifactId>
    			<version>2.5</version>
    			<scope>provided</scope>
    		</dependency>
    
    		<dependency>
    			<groupId>javax.servlet</groupId>
    			<artifactId>jsp-api</artifactId>
    			<version>2.0</version>
    			<scope>provided</scope>
    		</dependency>
    
    		<dependency>
    			<groupId>jstl</groupId>
    			<artifactId>jstl</artifactId>
    			<version>1.2</version>
    		</dependency>
    
    		<!-- hessian -->
    
    		<dependency>
    			<groupId>com.caucho</groupId>
    			<artifactId>hessian</artifactId>
    			<version>4.0.7</version>
    		</dependency>
    
    	</dependencies>
    	
    </project>
    i do not know how resolve this issue,any advice?
    thanks
Working...
X