Announcement Announcement Module
Collapse
No announcement yet.
Dynamic WSDL generation/exposure problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynamic WSDL generation/exposure problems

    Hello fellow developers,

    I'm having a hard time to make a very simple ws app work. Right now, after configuring everything by the book, or better, by the reference (v2.0) and my wsdl generation does not work. I want to know if I'm missing something on this specific configuration. So, with this on my spring-ws context:
    Code:
    	<ws:dynamic-wsdl id="alarm" portTypeName="Alarm"
    		locationUri="/services/">
    		<ws:xsd location="/WEB-INF/xsd/Alarms.xsd" />
    	</ws:dynamic-wsdl>
    And my web.xml mapping is:
    Code:
           <servlet-mapping>
    		<servlet-name>alarm-server</servlet-name>
    		<url-pattern>/*</url-pattern>
    	</servlet-mapping>
    I would have, theoretically, my wsdl published at
    http://localhost:8080/alarm-server/services/alarm.wsdl
    given that my servlet name is "alarm-server", but is always 404. The bean of class DefaultWsdl11Definition is created with id="alarm" and no error is reported on my log files in debug level.
    I'm deploying it to virgo-2.1.0 and with spring-ws-2.0.2.

    Tks for any help
    Paulo
    Last edited by paulo.mach; Jun 1st, 2011, 12:00 PM.

  • #2
    I've figured out that the problem was some package imports lacking in my MANIFEST.MF (to work inside the osgi).

    Comment

    Working...
    X