Announcement Announcement Module
No announcement yet.
OSGi Import Version Issue Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • OSGi Import Version Issue

    I'm using an OSGi bundle from the Springsource Enterprise Bundle Repository, . This bundle imports the package at version="[2.0.0,3.0.0)" (to clarify, this means greater than or equal to 2.0.0 and less than 3.0.0). This same import information still seems to be in the Spring WS trunk ( The package is provided by Spring Security Core, but that package doesn't seem to exist in versions of Spring Securtiy Core prior to 3.0.0. This is causing to be unable to resolve its dependency on Spring Security Core.

    Any ideas if this is a bug in Spring WS, or is there something I am not understanding?

    Thank you,