Announcement Announcement Module
Collapse
No announcement yet.
Spring Roo project creation doesn't respect jdk version settings Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Roo project creation doesn't respect jdk version settings

    I have set my Java Compiler in SpringSource Tool Suite 2.6.0.RELEASE (build 201103161000) to jdk 1.5, the JVM 1.5.0 (OS X default) is the only jre checked at "Installed JRE's", and under "Execution Environment" the JavaSE-1.6 has no compatible JRE visible while J2SE-1.5 have the JVM 1.5.0 checked.
    Yet, when I make a new Spring Roo project STS will instruct Roo to make the project with the option "-java 6" and in the properties STS have set project specific settings to jdk 1.6.
    It works like this up until that I redo the same settings (unchecking and rechecking for instance). Only then is my jdk settings respected at Roo project creation.

    JIRA: Spring Roo creation process doesn't respect jdk version settings of Java Compiler

  • #2
    Thanks for reporting this. Sounds indeed like an annoying thing that we should fix for the next STS version. Thanks for putting the JIRA in.

    -Martin

    Comment


    • #3
      I know this issue is still open, but thought I'd report. I'm new to STS and Roo, and have the same problem. I'm also on OS X 10.5.8, but using Version: 2.6.1.RELEASE. However, I have not been able to work around the issue as MiB did. I've set my STS compliance settings to JDK/JRE 1.5 in everyplace I could find, unchecking and rechecking as MiB indicated. It'd be nice to have here a documented work around until this is fixed. I also commented in JIRA. I cannot get past the Overview "start" demo for Roo.

      Comment


      • #4
        Currently in STS 2.6.0 Build Id: 201103161000, updated via "install new software" from the server at
        http://dist.springsource.com/snapsho...composite/e3.6 together with Roo 1.2.0BUILD-SNAPSHOT [rev 332b971] as well as with Roo 1.1.4Release, I don't have this particular problem. The same goes with STS 2.5.2SR1.

        Comment

        Working...
        X