Announcement Announcement Module
Collapse
No announcement yet.
new Spring Template gives input error at creation Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • new Spring Template gives input error at creation

    I made a Jira here: STS-1696: new Spring Template Project error at top level package input
    .

    Basically I couldn't make a new Spring Template Project as it doesn't work as it should with SpringSource Tool Suite 2.6.0.RELEASE(build 20110316).

  • #2
    Is the problem with the validation message that is displayed or that you can't create a project?

    If you enter a valid three level package name you should be able to create a project (e.g. com.mycompany.myapp)

    Comment


    • #3
      The problem was that even if I typed a reasonably valid package name, like what you propose or anything I usually use in other projects like Roo.like "com.company.domain", STS still claimed this was invalid and I couldn't continue with the creation.

      At revisiting however, it did work with the same naming convention. I suppose it's possible the error message triggered early and got stuck somehow. I've never seen this before though.
      Last edited by MiB; Mar 31st, 2011, 08:18 AM.

      Comment


      • #4
        I've only seen this error when I've typed the base package name in incorrectly.

        I wonder, if it's related to the type of project created? What type of project were you trying to create when this error occurred?

        Comment


        • #5
          I tried several project types, as I also suspected this at first. But no, it still gave me the same error. I simply think something, on my machine and related to the error message hung or got stuck intermittently. As I restarted STS it went away.

          I've yet to see this symptom in some other context in STS, so I'm not sure what to think of it. It seems gone now anyway.

          Comment

          Working...
          X