Announcement Announcement Module
Collapse
No announcement yet.
Cannot Install Grails Support in STS 2.6 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Is there any reason why you haven't installed STS straight from the zip file? You would avoid this whole problem of the missing dependency. You can get it here:

    http://springsource.com/developer/sts

    Comment


    • #17
      Yes, it fixed the problem. Thank you all for the help.

      Originally posted by Martin Lippert View Post
      Hi!



      Did that solve your problem?

      Cheers,
      -Martin

      Comment


      • #18
        Originally posted by Andrew Eisenberg View Post
        Is there any reason why you haven't installed STS straight from the zip file? You would avoid this whole problem of the missing dependency. You can get it here:

        http://springsource.com/developer/sts
        Mostly because I didn't know there was a difference and I had STS installed in eclipse for another project. It's working now however, thank you for your help.

        -Stephen

        Comment


        • #19
          Fundamentally, both ways of installing are the same, but as you have found out, it is trickier to install using the update sites since it is not guaranteed that all of the necessary prerequisite plugins are available. Let us know if you have any further problems.

          Comment


          • #20
            Getting the same error.

            Hello,
            I'm getting the same error. I tried the update url mentioned above. IT is still not working.
            Cannot complete the install because one or more required items could not be found.
            Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
            Missing requirement: SpringSource Tool Suite Grails Support (Core) 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.core 2.6.0.201103161000-RELEASE) requires 'bundle org.apache.commons.io 0.0.0' but it could not be found
            Cannot satisfy dependency:
            From: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
            To: com.springsource.sts.grails.core [2.6.0.201103161000-RELEASE]

            Comment


            • #21
              Hi!

              Thanks for attaching the information of your STS configuration, that helps a lot here. It seems like you are using STS installed into an Eclipse 3.5.2 and the org.apache.commons.io is indeed not part of your installation. Therefore I would recommend to add the Eclipse Orbit update site to the list of available update sites in order to have it available for the Grails support installation.

              So please add this update site (this is the latest release repo from Orbit) to your list of update sites (Preferences -> Install/Update -> Available Software Sites):

              http://download.eclipse.org/tools/or...754/repository

              After that you should be able to install the Grails support the same way as you tried before.

              HTH,
              Martin

              Comment


              • #22
                I have a similar problem. I've installed STS succesfully. But when I try to install Grails Support (or Groovy Support only), I get this error:

                Problems occurred while performing installation: Operation details
                Operation details
                Cannot complete the install because of a conflicting dependency.
                Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
                Software currently installed: Shared profile 1.0.0.1304534237271 (SharedProfile_com.springsource.sts.ide 1.0.0.1304534237271)
                Software currently installed: SpringSource Tool Suite 2.6.1.201105041000-RELEASE (com.springsource.sts.ide 2.6.1.201105041000-RELEASE)
                Only one of the following can be installed at once:
                Java Development Tools Core 3.6.2.xx-20110426-1500-e36 (org.eclipse.jdt.core 3.6.2.xx-20110426-1500-e36)
                Java Development Tools Core 3.6.2.v_A76_R36x (org.eclipse.jdt.core 3.6.2.v_A76_R36x)
                Cannot satisfy dependency:
                From: Shared profile 1.0.0.1304534237271 (SharedProfile_com.springsource.sts.ide 1.0.0.1304534237271)
                To: org.eclipse.jdt.core [3.6.2.v_A76_R36x]
                Cannot satisfy dependency:
                From: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
                To: org.codehaus.groovy.eclipse.feature.feature.group 2.0.0
                Cannot satisfy dependency:
                From: SpringSource Tool Suite 2.6.1.201105041000-RELEASE (com.springsource.sts.ide 2.6.1.201105041000-RELEASE)
                To: com.springsource.sts.package.feature.group [2.6.1.201105041000-RELEASE]
                Cannot satisfy dependency:
                From: SpringSource Tool Suite Package 2.6.1.201105041000-RELEASE (com.springsource.sts.package.feature.group 2.6.1.201105041000-RELEASE)
                To: org.eclipse.jdt.feature.group 0.0.0
                Cannot satisfy dependency:
                From: Groovy-Eclipse Feature 2.1.3.xx-20110426-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.3.xx-20110426-1500-e36)
                To: org.codehaus.groovy.jdt.patch.feature.group [2.1.3.xx-20110426-1500-e36]
                Cannot satisfy dependency:
                From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.3.xx-20110426-1500-e36 Eclipse Java Development Tools 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F (org.eclipse.jdt.feature.group 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F)
                To: org.eclipse.jdt.core [3.6.2.xx-20110426-1500-e36]

                Comment


                • #23
                  Hi AMsedian,

                  Your problem is slightly different. You are trying to install groovy-eclipse into a read-only installation of STS. That is what "Shared Install" means. There is no way to install Groovy-Eclipse into this kind of installation. This is a bug with the Eclipse p2 installer and it is currently out of our control.

                  However, the workaround is to temporarily give yourself write privileges to your STS install and retrying the installation process.

                  Comment


                  • #24
                    Originally posted by Andrew Eisenberg View Post
                    Hi AMsedian,

                    Your problem is slightly different. You are trying to install groovy-eclipse into a read-only installation of STS. That is what "Shared Install" means. There is no way to install Groovy-Eclipse into this kind of installation. This is a bug with the Eclipse p2 installer and it is currently out of our control.

                    However, the workaround is to temporarily give yourself write privileges to your STS install and retrying the installation process.
                    Hi! Thank you for the really quick reply!
                    Yes, you are right. I noticed that all the folders in the STS installation folder are set to 'read-only'. I gave myself all the privileges and could succesfully instal Grails support.

                    Thank you very much,
                    have a nice day!

                    Alex B.

                    Comment

                    Working...
                    X