Announcement Announcement Module
Collapse
No announcement yet.
Cannot Install Grails Support in STS 2.6 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot Install Grails Support in STS 2.6

    I am learning Grails and just installed STS 2.6. I then installed Grails (current production release) and Groovy Eclipse, but Grails Support will not install. It gives me the following error:

    Problems occurred while performing installation: Operation details
    Operation details
    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
    Missing requirement: SpringSource Tool Suite Grails Support (Core) 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.core 2.6.0.201103161000-RELEASE) requires 'bundle org.apache.commons.io 0.0.0' but it could not be found
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
    To: com.springsource.sts.grails.core [2.6.0.201103161000-RELEASE]
    Is this file temporarily unavailable or is there something wrong?

  • #2
    Hi!

    Typically org.apache.commons.io is part of the STS download (or your Eclipse EE installation). Did you download STS as complete package or did you install STS into an existing Eclipse installation (via "Install New Software")?

    -Martin

    Comment


    • #3
      I installed STS into an existing Eclipse EE installation. This installation was downloaded from PortableApps.com.

      Comment


      • #4
        Make sure that when you perform the install that "Contact all update sites..." is checked in your update manager.

        Comment


        • #5
          I have the same issue. I'm trying to install grails support on OSX, and the option for "contact all update sites" is checked. Still no luck.

          Cannot complete the install because one or more required items could not be found.
          Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
          Missing requirement: SpringSource Tool Suite Grails Support (Core) 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.core 2.6.0.201103161000-RELEASE) requires 'bundle org.apache.commons.io 0.0.0' but it could not be found
          Cannot satisfy dependency:
          From: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
          To: com.springsource.sts.grails.runonserver [2.6.0.201103161000-RELEASE]
          Cannot satisfy dependency:
          From: SpringSource Tool Suite Grails Debug/Run on Server Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.runonserver 2.6.0.201103161000-RELEASE)
          To: bundle com.springsource.sts.grails.core 0.0.0

          Comment


          • #6
            I reverted to a previous configuration. Then I installed STS using Install New Software. I had been using The Eclipse Marketplace. I don't know if the Marketplace points to a different package or something.

            Comment


            • #7
              A previous configuration of what? Eclipse? How?

              Will try using the "Install new software" method instead.

              Comment


              • #8
                Previous Configuration

                Originally posted by Raquo View Post
                A previous configuration of what? Eclipse? How?

                Will try using the "Install new software" method instead.
                In Eclipse Help -> About Eclipse -> Installation Details -> Installation History tab. Select a date under Previous configurations, then click Revert Button at the bottom of the window.

                Comment


                • #9
                  Hi!

                  Originally posted by Byrill View Post
                  I reverted to a previous configuration. Then I installed STS using Install New Software. I had been using The Eclipse Marketplace. I don't know if the Marketplace points to a different package or something.
                  Did that solve your problem?

                  Cheers,
                  -Martin

                  Comment


                  • #10
                    Hi,
                    I got the same error using STS 2.6. Don't install the grails plugin with the Eclipse Marketplace, but use the STS Install Manager and it will work.
                    Kind regards, Philipp.

                    Comment


                    • #11
                      Hi.

                      I am also receiving this same error message.

                      I downloaded STSS from the eclipse marketplace earlier today and was able to download the current release of Grails and Groovy Eclipse from the STSS Install Manager, however, Grails Support will not install from the STSS Install Manager. Any other suggestions?

                      I'm using Eclipse Helios SR 2 (3.6.2) and STSS 2.60.

                      It says I'm up to date if I check for updates, and I've added all the Mylyn urls I could find to the software site list (say that "fix" on another site).

                      Thanks,
                      -Stephen

                      Comment


                      • #12
                        Why can you not install Grails support from the install manager? Is there an error report or an entry in the error log?

                        Comment


                        • #13
                          Same issue everyone else seems to have been having in this thread:


                          Code:
                          Problems occurred while performing installation: Operation details
                          Operation details
                          Cannot complete the install because one or more required items could not be found.
                          Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
                          Missing requirement: SpringSource Tool Suite Grails Support (Core) 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.core 2.6.0.201103161000-RELEASE) requires 'bundle org.apache.commons.io 0.0.0' but it could not be found
                          Cannot satisfy dependency:
                          From: SpringSource Tool Suite Grails Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201103161000-RELEASE)
                          To: com.springsource.sts.grails.runonserver [2.6.0.201103161000-RELEASE]
                          Cannot satisfy dependency:
                          From: SpringSource Tool Suite Grails Debug/Run on Server Support 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.runonserver 2.6.0.201103161000-RELEASE)
                          To: bundle com.springsource.sts.grails.core 0.0.0

                          Comment


                          • #14
                            This problem happens because you did not install STS in the preferred way. You do not have org.apache.commons.io installed in your STS.

                            Instead of going through the install manager, go to Help -> Install New Software. Select this update site (add it if it is not there): http://dist.springsource.com/release...vy-grails/e3.6

                            Make sure that "Contact all update sites..." is selected.

                            Then try installing Grails. This will probably work, but if not, then there are other things we can do. Let me know.

                            Comment


                            • #15
                              Thanks for your help so far Andrew.

                              I checked the update site and that was listed and "Contact all update sites..." was already selected. So just to be sure, I uninstalled STS and reinstalled it through the Help -> Install New Software dialogue, and I am still receiving the same issue when I try to install Grails Support.

                              -Stephen

                              Comment

                              Working...
                              X