Announcement Announcement Module
Collapse
No announcement yet.
2.6.0.RELEASE, Ubuntu 10.10 stuck updating maven dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2.6.0.RELEASE, Ubuntu 10.10 stuck updating maven dependencies

    Hi all, I've tried both the sh installer and the full download of 2.6.0.RELEASE, eclipse 3.6.2 and it gets stuck updating maven dependencies forever. The only way to stop it is by setting maven to offline; then it stops but as soon as you set it up again (to download any dependency) it is stuck again.

    Projects won't build cause they are waiting for the update to finish. I left it during lunch hoping for it to finish but nope, no luck.

    Anyone else noticing anything similar? I use Ubuntu 10.10 on a Dell Precision M4500.

    Thanks,
    Jos

  • #2
    me 3

    I too am having the same problem.
    I started to have it after importing all of the 3.0.4 spring-samples.

    I had https://src.springframework.org/svn/spring-samples checked out to folder on my hdd and imported them as existing projects.

    STS won't close and a project, that was ok before, has errors in it.

    OS: win xp sp3

    console maven output

    last line in my console:
    Code:
    1.05.11 0:28:00 EEST: Downloaded http://repository.springsource.com/maven/bundles/release/org/apache/tiles/tiles-api/2.2.0/tiles-api-2.2.0.pom
    Last edited by Nullington; Apr 30th, 2011, 05:37 PM.

    Comment


    • #3
      Does the issue occur in Eclipse with m2e installed too? If you are downloading a lot of new dependencies, it may be related to this issue. A workaround I have used before is to resolve the dependencies with the commandline first and then import it into eclipse.

      HTH,

      Comment


      • #4
        I'm having this same problem on Win7 64 Bit. It just hangs and nothing never really happens.

        Comment


        • #5
          I have STS 2.6.0 on Ubuntu and XP, and never have an issue - though both of my installations have been upgrades dating back to the beginning of STS ( I think I may have started from scratch on 2.5.0)

          Comment


          • #6
            Hi!

            Can you check your network settings? I just wonder if a firewall/proxy setting might prevent you from updating the maven dependencies.

            -Martin

            Comment

            Working...
            X