Announcement Announcement Module
Collapse
No announcement yet.
Problem with expenses.roo sample and STS 2.6.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with expenses.roo sample and STS 2.6.0

    From STS with the Google Plugin for Eclipse installed, I create a new roo project. Then I run the expenses.roo script (less the project command because STS has already created it) and I add the following just before the gwt setup command:

    dependency add --groupId com.google.appengine --artifactId appengine-api-1.0-sdk --version 1.4.0

    Without this I get errors 12 java errors about missing google app engine imports. It appears to compile ok. I then right click on project and select debug as/web application selecting ApplicationScaffold.html. The google development mode appears with localhost URL (actually a 127.0.0.1 URL). I invoke it from Firefox 3.6 and it takes approximately 30 seconds to start. All seems to be working.

    Then I right mouse click on the SpringSource rc Server Developer Edition v2.1 and click add remove and add the roo project. Then in Firefox, I navigate to http://localhost:8080/exp/ApplicationScaffold.html and I get a small grey window that says "loading". That's all I ever get. Note that there is no error in the server console or no google app engine involvement either in expenses.roo.

    I am the guy that likes to ask multiple questions per post, so here they are:
    1. Why do I need to add the dependency add roo shell command and what is its effect?
    2. Should the dependency add be added to the expenses.roo sample?
    3. Why was the dependency add not required in previous versions of STS like version 2.5.2 (no so long ago)?
    4. Why does the project not run in the SpringSource tc Server which is really a Tomcat 6 server?

  • #2
    I believe I know the root cause of question 4. When I look at the project property/Deployment Assembly, I should see an entry for the folder where the output of the compilation will go. In my case, this folder only appears after the first compilation and it is found in the following project folder:

    target/exp-0.1.0.BUILD-SNAPSHOT/applicationScaffold

    If after compiling I add to the deployment assembly the following entry:

    Source: target/exp-0.1.0.BUILD-SNAPSHOT/applicationScaffold
    Deploy Path: applicationScaffold

    and I redeploy to tc Server, all seem to work with no problem. I don't know if the development mode would still work after this. I will refer to this thread in the an issue I have reported for the problem that occurs when the dependency add statement is not added.

    Comment


    • #3
      I don't know what's up with the samples. They aren't being maintained as STS changes. STS needs regression testing.
      But to get the expenses sample working for the current version (extrack)...
      In STS:
      Edit the project properties
      Select Deployment Assembly
      Click Add
      Select Folder
      Select target/extrack-0.1.0.BUILD-SNAPSHOT (or whatever your version is)
      Click Finish
      Right click on the project or the pom.xml
      Select Run As -> Maven assembly:assembly
      App should re-deploy to the server

      That at least worked for me.

      Comment

      Working...
      X