Announcement Announcement Module
No announcement yet.
Missing menu bar Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing menu bar

    Hello everybody.

    This is my first post and this is the first time I try do download STS, 'cause I need it at work.

    A strange thing happen once installed ST on Ubuntu 11.04.

    The menu bar doesn't appear, as you can check in the attached screenshot.

    In the image, Windows menu is visible, but other times they are all missing.

    I tried to deactivate and activate them back from Window > Customize Perpective (they were already selected but I turned them off, I confirmed, and then turned them on again), and it works as long as I don't close the application.
    The next time I start it again, menu bar is still missing.

    Another strange thing is that it appears ABOVE the titlebar instead of between icons and title bar, as I expected.

    Note this is the first time I use Linux, since I always have been a Windows user.

    Thank you
    Last edited by AZbarra3; Mar 28th, 2011, 11:02 AM.

  • #2
    Nobody could help me?



    • #3
      Hi Azbarra,

      I'm a Ubuntu linux user myself and I haven't seen this problem myself. I am not using 11.X ubuntu yet so maybe that makes a difference.

      I'm using 10.04. Perhaps this is a good time for me to try and install Ubuntu 11.X on a spare computer and try it out.

      Some other thing I can think of that might make a difference is what version of Java you have installed. I always recommend people to use the Sun JVM as it is more widely used and things are generally better tested and more stable with that.

      Unfortunately Ubuntu not too long ago decided to start shipping with OpenJDK on principle. I do agree with the principle, but at the same time I really prefer something that works with the least amount of trouble.

      Luckily you can still install sun JDK from the synaptic package manager.

      Go to System >> Administration >> Synaptic package manager

      Then search for sun-java6. Then select sun-java6-jdk and install that. It should replace your open jdk install.

      Maybe that isn't the problem here, but in any case I recommend using sun-jvm as I'm sure it will save you trouble down the line.

      Try that and let me know how it goes.

      In the mean time, I'll try to install Ubuntu 11.X on another machine. I guess we'll see more user starting to use that, so its probably a good idea for me to try that out and see what happens.



      • #4
        Hmm... I just went to Ubuntu download site and there isn't a 11.X version there yet. Where did you get version 11.04?


        • #5
          Originally posted by Kris De Volder View Post
          Hmm... I just went to Ubuntu download site and there isn't a 11.X version there yet. Where did you get version 11.04?
          I've found it installed on the PC it wqas gave me at work, my first day.
          It's not a stable release, it's an ALPHA version.

          I surely prefer to towngrade to a stable release, and maybe I'll do it during nights or Sundays, since I found a few little problems in this version, such as some Linux system crash!

          After doing that, I will try to reinstall JDK, as you suggest.

          In the meantime, I found how to install Eclipse base version and then install STS plugins on it. Hope this makes the same software as downloading STS from scratch.

          Thank you.


          • #6
            The Ubuntu 10.04 version, that's the most recent one currently marked for LTS (long time support), has been working quite well for me, so I would recommend that one, if you are looking to reinstall.

            Another thing I suggest is that you install 32 bit version, unless you have more than 4Gb of memory in your computer. I found it to be more stable, and, especially more memory efficient when running the JVM in 32 bit. It is also possible to run 32 bit VM in 64 bit OS, but it takes a lot more customized setup to get that working.

            If you have more than 4Gb of memory, you should of course install the 64 bit version to make use of the extra memory. Since you'd have more memory you'd be less concerned with using more memory for a 64 bit VM.

            Hope this helps.

            Follow up on this message to let me know how things work out re that problem using STS.



            • #7
              I reinstalled Ubuntu.
              A whole night to try to backup the old system, in case the new installation would have gone bad.

              Had to find out a proper software to do that job, mine configured for Windows weren't working.

              After doing that, I made the installation.
              What a surprise when I found out that the new OS installation would preserve Ubuntu 11.04 with dual boot and, in addition, the whole old file system could be mounted as an external file system.

              In any case, it worked.
              Now STS is showing icons and menu bar properly.

              Thank you!

              Last edited by AZbarra3; Apr 4th, 2011, 07:57 AM.


              • #8
                Great! I'm glad that worked. It would have been really annoying if you'd had gone through all that trouble and it didn't work. I hate to even think of it :-)


                • #9
                  I'm using STS with Ubuntu 11.04 and noticed the problem with the menus disappearing today. I also found that if I reset the perspective, they come back. You can do this from the Window menu, or if that's one of the ones that took a vacation, you can right-click on the perspective button at the top-right of the application window. Hope this helps.


                  • #10
                    I've just run into the exact same issue, now that 11.04 is out, and by chance found the solution.

                    I started up STS 2.6.0 RELEASE, and could only see the Window option in the top menu. Then STS prompted for update I let it download and install STS 2.6.1 RELEASE. When it restarted, same problem.

                    On a hunch, I hit Window -> Reset Perspective. Once the perspective is reset to default, all the rest of the menus were functioning. Hopefully that helps someone.

                    Haha, and beaten to the punch by 5 mins.


                    • #11
                      Another user has reported the same problem:


                      There is a workaround and a link to an Ubuntu bug report.


                      • #12
                        Originally posted by Brad Murray View Post
                        Haha, and beaten to the punch by 5 mins.
                        That's funny. You snooze you lose!