Announcement Announcement Module
Collapse
No announcement yet.
Unable to launch STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to launch STS

    I'm trying to get started with Spring and the STS but haven't been able to get very far. I used springsource-tool-suite-2.6.0.RELEASE-e3.6.2-win32-installer.exe to install the new STS to my Windows XP pc. It appears to successfully complete, but when I launch the STS, I get an error message directing me to a configuration log. Here are some lines near the end of that lengthy log file:

    !MESSAGE Missing imported package org.springframework.ide.eclipse.webflow.ui.editor. outline.webflow_0.0.0.

    !ENTRY org.eclipse.osgi 4 0 2011-03-20 15:11:00.265
    !MESSAGE Application error
    !STACK 1
    java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.datatools.connectivity.console.profile .StorageFileEditor, org.eclipse.emf.codegen.CodeGen, org.eclipse.emf.codegen.JMerger, org.eclipse.emf.codegen.ecore.Generator,



    Any suggestions on how to resolve this error?

    Thanks,
    Steve

  • #2
    I've resolved the issue by abandoning the results of the installer and, instead, using 7-Zip to extract the files from springsource-tool-suite-2.6.0.RELEASE-e3.6.2-win32.zip.

    Out of curiosity, I used WinMerge to compare the directories produced by the installer and the zip file. Of the 4220 total items, there are 371 differences, most of which appear to just be timestamps off by either an hour or a second. However, the 371 also includes 131 files or folders that exist in one directory structure but not the other.

    Comment


    • #3
      Hey Steve!

      Glad to hear that you solved the problem by using the ZIP package for Windows. Nevertheless it seems strange that the installer put 131 files less on your drive than the ZIP. But that matches your error message and clearly looks like the installer didn't run correctly on your machine. Can you try the installer again to see if it produces the same strange result again?

      Thanks!
      -Martin

      Comment


      • #4
        I tried the installer again and when I launch the resulting STS, the application does successfully start but the dashboard crashes:

        org.eclipse.ui.PartInitException: Cannot instantiate input element factory com.springsource.sts.ide.ui.dashboard.elementFacto ry for editor id=com.springsource.sts.internal.ide.ui.editors.Mu ltiPageDashboardEditor name=Dashboard
        at org.eclipse.ui.internal.EditorReference.getRestore dInput(EditorReference.java:398)
        at org.eclipse.ui.internal.EditorReference.getEditorI nput(EditorReference.java:365)
        at org.eclipse.ui.internal.EditorReference.createPart Helper(EditorReference.java:594)
        at org.eclipse.ui.internal.EditorReference.createPart (EditorReference.java:465)
        at org.eclipse.ui.internal.WorkbenchPartReference.get Part(WorkbenchPartReference.java:595)
        at org.eclipse.ui.internal.EditorAreaHelper.setVisibl eEditor(EditorAreaHelper.java:271)
        at org.eclipse.ui.internal.EditorManager.setVisibleEd itor(EditorManager.java:1429)
        ...


        When I launch the zip version of the STS, the application starts and the dashboard loads fine. I do get an error about eclipse running in a JRE instead of a JDK.

        Winmerge shows that, between the installer and zip version of the STS, there are 245 different files (though most appear to just be timestamp differences) and 99 items that exist in only one or the other version.

        I'm just going to stick with the zip version and delete the other.

        Comment


        • #5
          Hi Steve!

          Thanks for trying again, its still strange that the installer doesn't produce the correct installation. Anyway, working with the ZIP is a good choice... :-)

          Cheers,
          -Martin

          Comment

          Working...
          X