Announcement Announcement Module
Collapse
No announcement yet.
STS 2.6.0 released Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.6.0 released

    Dear Spring Community,

    I'm pleased to announce that we just released SpringSource Tool Suite (STS) 2.6.0.

    Some highlights from this release:
    • All the updates that you got from 2.5.2.SR1 included (Spring Roo 1.1.2, Eclipse Helios SR2, Groovy 1.7.8, Grails 1.3.7)
    • Roo Plugin Manager
    • Content Assist, Quick Fixes and Refactorings for @Autowired, @Qualifier, @RequestMapping
    • New graphical editor for Spring Web Flow
    • A lot of new features and performance improvements for Groovy + Grails tooling
    More details can be found in the New and Noteworthy document. Detailed installation instructions are also available.

    As always downloads are available from the STS download page.

    Regards,
    Martin

  • #2
    Hi,

    It's the first release I've tried. Seems to be promising

    I've found 2 bugs though.
    Where can I submit them?

    For now here their goes:
    1. STS IDE complains about dynamic getter implementation.
      Sample interface and implementing class in groovy (split into different files):
      Code:
      interface Addressable {
          def getAddress()
      }
      
      class User implements Addressable {
          def address
      }
      The code above is enough to fulfil interface implementation in groovy however IDE shows "The class 'test.User' must be declared abstract or the method 'java.lang.Object getAddress()' must be implemented."
    2. If grails domain class implements itself (I believe any other class too, but haven't checked) IDE crashes - StackOverFlowException via infinite recurrency. This isn't crucial as something like
      Code:
      class User implements User ...
      can be written only by accident. Still it's not good when this cannot be undone without using other editor.

    I'm on Ubuntu 9.10 (kernel 2.6.31-22) 64 bit, OpenJDK 1.6.0_20

    BTW. Is there plan for adding visual domain designer?

    Regards,
    topr
    Last edited by topr; Mar 20th, 2011, 09:44 AM.

    Comment


    • #3
      Hi Topr,

      Re: 1

      Please raise an issue on https://issuetracker.springsource.com/browse/STS and we can explore that problem.

      Re: 2

      This is already logged as https://jira.codehaus.org/browse/GRECLIPSE-531

      cheers
      Andy
      ---
      Andy Clement
      SpringSource Tool Suite team

      Comment


      • #4
        create-app problem after upgrade

        Hi,
        I upgraded to 2.6.0 and am getting the following error when trying to create a new project.

        GrailsCommand(create-app myproject) has encountered a problem.

        An internal error occurred during: "GrailsCommand(create-app myproject)".
        java.lang.NullPointerException

        I downloaded the following and did a clean install : springsource-tool-suite-2.6.0.RELEASE-e3.6.2-macosx-cocoa-installer.dmg


        Afterwards, I installed the Grails extensions.

        I have the following defined in my .profile

        export GRAILS_HOME=/Users/brian/springsource/grails-1.3.7

        my JAVA_HOME and PATH haven't changed and resolve correctly. From the command line I can invoke grails create-app and it works. Inside STS, preferences > Grails > Grails Installations points to the same installation directory. I've uninstalled and reinstalled STS several times and still get the same error. I was wondering if there's another place on a mac where a setting might get set. I've noticed a ~/.grails folder and it has 1.3.7 folder in it. Any help is appreciated.

        Thanks,
        Brian

        Comment


        • #5
          STS update for eclipse 3.6

          As per the installation instructions for installing STS 2.6 into eclipse using an update site, i'm getting error related to MD5 hash failing for a jar while doing an update.
          Env: eclipse 3.6
          o/s: Windows 7 64 bit

          Attached is the image for reference. let me know what needs to be done for this error.

          Thanks

          Comment


          • #6
            should we be able to point the newly installed version 2.6 sts at a previous sts workspace? I'm not able to do so for a workspace in which i was using plugins, the errors in the log show:

            !ENTRY org.eclipse.team.core 4 0 2011-03-28 19:56:10.582
            !MESSAGE Could not instantiate provider org.tigris.subversion.subclipse.core.svnnature for project ******
            !STACK 1
            org.eclipse.team.core.TeamException: Could not instantiate provider org.tigris.subversion.subclipse.core.svnnature for project yardmap-static.
            at org.eclipse.team.core.RepositoryProvider.mapNewPro vider(RepositoryProvider.java:165)
            at org.eclipse.team.core.RepositoryProvider.mapExisti ngProvider(RepositoryProvider.java:235)
            at org.eclipse.team.core.RepositoryProvider.getProvid er(RepositoryProvider.java:507)
            at org.eclipse.team.internal.core.TeamHookDispatcher. getProvider(TeamHookDispatcher.java:97)
            at org.eclipse.team.internal.core.TeamHookDispatcher. getRuleFactory(TeamHookDispatcher.java:105)
            at org.eclipse.core.internal.resources.Rules.factoryF or(Rules.java:92)
            at org.eclipse.core.internal.resources.Rules.modifyRu le(Rules.java:144)
            at org.eclipse.core.internal.resources.Project.touch( Project.java:1268)
            at org.eclipse.jdt.internal.core.SetContainerOperatio n.executeOperation(SetContainerOperation.java:115)
            at org.eclipse.jdt.internal.core.JavaModelOperation.r un(JavaModelOperation.java:728)
            at org.eclipse.core.internal.resources.Workspace.run( Workspace.java:1975)
            at org.eclipse.jdt.internal.core.JavaModelOperation.r unOperation(JavaModelOperation.java:793)
            at org.eclipse.jdt.internal.core.JavaModelManager$11. run(JavaModelManager.java:2637)
            at org.eclipse.core.internal.resources.Workspace.run( Workspace.java:1975)
            at org.eclipse.jdt.internal.core.JavaModelManager.ini tializeAllContainers(JavaModelManager.java:2653)
            at org.eclipse.jdt.internal.core.JavaModelManager.get ClasspathContainer(JavaModelManager.java:1845)
            at org.eclipse.jdt.core.JavaCore.initializeAfterLoad( JavaCore.java:3463)
            at org.eclipse.jdt.internal.ui.InitializeAfterLoadJob $RealJob.run(InitializeAfterLoadJob.java:35)
            at org.eclipse.core.internal.jobs.Worker.run(Worker.j ava:54)

            Comment


            • #7
              Looks like the Subclipse plugin is missing. Please go to the extension install (on the STS dashboard) and install Subclipse into your fresh STS installation, that should solve this problem.

              HTH,
              Martin

              Comment


              • #8
                I tried to install STS 2.6.0 into an existing Eclipse 3.6.2 on Win7 64bit and it works without the MD5 problem. I added these two update sites:

                http://dist.springsource.com/release/TOOLS/update/e3.6
                http://dist.springsource.com/release...composite/e3.6

                and then installed everything from STS by choosing the first one and selecting the components I wish to use. Works fine for me. Can you check the update sites?

                BTW: Are you behind a firewall? Maybe the firewall unzip and re-zip JAR files to check for malware...

                HTH,
                Martin

                Comment


                • #9
                  thanks! i pointed the new sts at a fresh workspace, installed the plugins from the dashboard, then moved back to the old workspace, and it doesn't just freeze and crash

                  Comment


                  • #10
                    ack, so close. was experiencing the problem mentioned in this post -

                    http://forum.springsource.org/showthread.php?t=106348

                    and now sts/eclipse freezes on startup with the following error in the log:



                    !ENTRY org.maven.ide.eclipse 4 0 2011-03-29 11:45:11.199
                    !MESSAGE Can't read workspace state
                    !STACK 0
                    java.io.OptionalDataException
                    at java.io.ObjectInputStream.readObject0(ObjectInputS tream.java:1348)
                    at java.io.ObjectInputStream.readObject(ObjectInputSt ream.java:350)
                    at org.maven.ide.eclipse.internal.project.registry.Pr ojectRegistryReader$1.resolveClass(ProjectRegistry Reader.java:80)
                    at java.io.ObjectInputStream.readNonProxyDesc(ObjectI nputStream.java:1574)
                    at java.io.ObjectInputStream.readClassDesc(ObjectInpu tStream.java:1495)
                    at java.io.ObjectInputStream.readOrdinaryObject(Objec tInputStream.java:1731)
                    at java.io.ObjectInputStream.readObject0(ObjectInputS tream.java:1328)
                    at java.io.ObjectInputStream.readObject(ObjectInputSt ream.java:350)
                    at org.maven.ide.eclipse.internal.project.registry.Pr ojectRegistryReader.readWorkspaceState(ProjectRegi stryReader.java:95)
                    at org.maven.ide.eclipse.internal.project.registry.Pr ojectRegistryManager.<init>(ProjectRegistryManager .java:150)
                    at org.maven.ide.eclipse.MavenPlugin.start(MavenPlugi n.java:224)
                    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$1.run(BundleContextImpl.java:783)
                    at java.security.AccessController.doPrivileged(Native Method)
                    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:774 )
                    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:755)
                    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:370)
                    at org.eclipse.osgi.framework.internal.core.AbstractB undle.start(AbstractBundle.java:284)
                    at org.eclipse.osgi.framework.util.SecureAction.start (SecureAction.java:417)
                    at org.eclipse.osgi.internal.loader.BundleLoader.setL azyTrigger(BundleLoader.java:265)
                    at org.eclipse.core.runtime.internal.adaptor.EclipseL azyStarter.postFindLocalClass(EclipseLazyStarter.j ava:106)
                    at org.eclipse.osgi.baseadaptor.loader.ClasspathManag er.findLocalClass(ClasspathManager.java:453)
                    at org.eclipse.osgi.internal.baseadaptor.DefaultClass Loader.findLocalClass(DefaultClassLoader.java:216)
                    at org.eclipse.osgi.internal.loader.BundleLoader.find LocalClass(BundleLoader.java:393)
                    at org.eclipse.osgi.internal.loader.BundleLoader.find ClassInternal(BundleLoader.java:469)
                    at org.eclipse.osgi.internal.loader.BundleLoader.find Class(BundleLoader.java:422)
                    at org.eclipse.osgi.internal.loader.BundleLoader.find Class(BundleLoader.java:410)
                    at org.eclipse.osgi.internal.baseadaptor.DefaultClass Loader.loadClass(DefaultClassLoader.java:107)
                    at java.lang.ClassLoader.loadClass(ClassLoader.java:2 48)
                    at org.eclipse.osgi.internal.loader.BundleLoader.load Class(BundleLoader.java:338)
                    at org.eclipse.osgi.framework.internal.core.BundleHos t.loadClass(BundleHost.java:232)
                    at org.eclipse.osgi.framework.internal.core.AbstractB undle.loadClass(AbstractBundle.java:1197)
                    at org.eclipse.core.internal.registry.osgi.RegistrySt rategyOSGI.createExecutableExtension(RegistryStrat egyOSGI.java:174)
                    at org.eclipse.core.internal.registry.ExtensionRegist ry.createExecutableExtension(ExtensionRegistry.jav a:904)
                    at org.eclipse.core.internal.registry.ConfigurationEl ement.createExecutableExtension(ConfigurationEleme nt.java:243)
                    at org.eclipse.core.internal.registry.ConfigurationEl ementHandle.createExecutableExtension(Configuratio nElementHandle.java:55)
                    at org.eclipse.core.internal.content.ContentType.getD escriber(ContentType.java:271)
                    at org.eclipse.core.internal.content.ContentTypeCatal og.collectMatchingByContents(ContentTypeCatalog.ja va:184)
                    at org.eclipse.core.internal.content.ContentTypeCatal og.internalFindContentTypesFor(ContentTypeCatalog. java:403)
                    at org.eclipse.core.internal.content.ContentTypeCatal og.internalFindContentTypesFor(ContentTypeCatalog. java:450)
                    at org.eclipse.core.internal.content.ContentTypeCatal og.getDescriptionFor(ContentTypeCatalog.java:346)
                    at org.eclipse.core.internal.content.ContentTypeCatal og.getDescriptionFor(ContentTypeCatalog.java:360)
                    at org.eclipse.core.internal.content.ContentTypeMatch er.getDescriptionFor(ContentTypeMatcher.java:86)
                    at org.eclipse.core.internal.resources.ContentDescrip tionManager.readDescription(ContentDescriptionMana ger.java:436)
                    at org.eclipse.core.internal.resources.ContentDescrip tionManager.getDescriptionFor(ContentDescriptionMa nager.java:346)
                    at org.eclipse.core.internal.resources.File.internalG etCharset(File.java:255)
                    at org.eclipse.core.internal.resources.File.getCharse t(File.java:216)
                    at org.eclipse.core.internal.resources.File.getCharse t(File.java:203)
                    at org.eclipse.core.internal.filebuffers.ResourceText FileBuffer.cacheEncodingState(ResourceTextFileBuff er.java:479)
                    at org.eclipse.core.internal.filebuffers.ResourceText FileBuffer.initializeFileBufferContent(ResourceTex tFileBuffer.java:281)
                    at org.eclipse.core.internal.filebuffers.ResourceFile Buffer.create(ResourceFileBuffer.java:245)
                    at org.eclipse.core.internal.filebuffers.TextFileBuff erManager.connect(TextFileBufferManager.java:112)
                    at org.eclipse.ui.editors.text.TextFileDocumentProvid er.createFileInfo(TextFileDocumentProvider.java:55 9)
                    at org.eclipse.ui.editors.text.TextFileDocumentProvid er.connect(TextFileDocumentProvider.java:478)
                    at org.eclipse.ui.texteditor.AbstractTextEditor.doSet Input(AbstractTextEditor.java:4056)
                    at org.eclipse.ui.texteditor.StatusTextEditor.doSetIn put(StatusTextEditor.java:217)
                    at org.eclipse.ui.texteditor.AbstractDecoratedTextEdi tor.doSetInput(AbstractDecoratedTextEditor.java:14 44)
                    at org.eclipse.ui.editors.text.TextEditor.doSetInput( TextEditor.java:169)
                    at org.eclipse.wst.sse.ui.StructuredTextEditor.doSetI nput(StructuredTextEditor.java:1908)
                    at org.eclipse.ui.texteditor.AbstractTextEditor$19.ru n(AbstractTextEditor.java:3043)
                    at org.eclipse.jface.operation.ModalContext.runInCurr entThread(ModalContext.java:464)
                    at org.eclipse.jface.operation.ModalContext.run(Modal Context.java:372)
                    at org.eclipse.jface.window.ApplicationWindow$1.run(A pplicationWindow.java:759)
                    at org.eclipse.swt.custom.BusyIndicator.showWhile(Bus yIndicator.java:70)
                    at org.eclipse.jface.window.ApplicationWindow.run(App licationWindow.java:756)
                    at org.eclipse.ui.internal.WorkbenchWindow.run(Workbe nchWindow.java:2606)
                    at org.eclipse.ui.texteditor.AbstractTextEditor.inter nalInit(AbstractTextEditor.java:3061)
                    at org.eclipse.ui.texteditor.AbstractTextEditor.init( AbstractTextEditor.java:3088)
                    at org.eclipse.wst.sse.ui.StructuredTextEditor.init(S tructuredTextEditor.java:2553)
                    at org.eclipse.ui.part.MultiPageEditorPart.addPage(Mu ltiPageEditorPart.java:237)
                    at org.eclipse.ui.part.MultiPageEditorPart.addPage(Mu ltiPageEditorPart.java:211)
                    at org.eclipse.wst.xml.ui.internal.tabletree.XMLMulti PageEditorPart.addSourcePage(XMLMultiPageEditorPar t.java:493)
                    at org.eclipse.wst.xml.ui.internal.tabletree.XMLMulti PageEditorPart.createPages(XMLMultiPageEditorPart. java:713)
                    at org.eclipse.ui.part.MultiPageEditorPart.createPart Control(MultiPageEditorPart.java:348)
                    at org.eclipse.ui.internal.EditorReference.createPart Helper(EditorReference.java:670)
                    at org.eclipse.ui.internal.EditorReference.createPart (EditorReference.java:465)
                    at org.eclipse.ui.internal.WorkbenchPartReference.get Part(WorkbenchPartReference.java:595)
                    at org.eclipse.ui.internal.EditorAreaHelper.setVisibl eEditor(EditorAreaHelper.java:271)
                    at org.eclipse.ui.internal.EditorManager.setVisibleEd itor(EditorManager.java:1429)
                    at org.eclipse.ui.internal.EditorManager$5.runWithExc eption(EditorManager.java:942)
                    at org.eclipse.ui.internal.StartupThreading$StartupRu nnable.run(StartupThreading.java:31)
                    at org.eclipse.swt.widgets.RunnableLock.run(RunnableL ock.java:35)
                    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessa ges(Synchronizer.java:134).........

                    Comment


                    • #11
                      I'm already running milestone 2 via exe on Win7 - would/should I uninstall/reinstall, or is there a simpler method of upgrading?

                      Comment


                      • #12
                        Originally posted by JGarrido View Post
                        I'm already running milestone 2 via exe on Win7 - would/should I uninstall/reinstall, or is there a simpler method of upgrading?
                        Yes, just do a "Check for Updates" and install the release, when it shows up.

                        If you haven't installed a lot of other plugins into your installation, a new fresh install is of course also an option.

                        HTH,
                        Martin

                        Comment


                        • #13
                          Originally posted by chrismarx View Post
                          ack, so close. was experiencing the problem mentioned in this post -

                          http://forum.springsource.org/showthread.php?t=106348

                          and now sts/eclipse freezes on startup with the following error in the log:



                          !ENTRY org.maven.ide.eclipse 4 0 2011-03-29 11:45:11.199
                          !MESSAGE Can't read workspace state
                          !STACK 0
                          java.io.OptionalDataException
                          at
                          Looks like the workspace got corrupted. Did you try to run a fresh workspace? If that works, you might need to create a new workspace for your project. The easiest way is to delete the .metadata directory, start STS with the same workspace location as before and re-import the still existing projects. Sorry for the inconvenience.

                          HTH,
                          Martin

                          Comment


                          • #14
                            Windows 7 Supported?

                            The STS download page says:

                            "Operating System: Microsoft Windows XP or Vista, Apple Mac OS X, Linux"

                            I think Windows 7 is here to stay, so maybe it should be added to the list? (And Vista discouraged. )

                            jack

                            Comment


                            • #15
                              great, ill give that a try-

                              Comment

                              Working...
                              X