Announcement Announcement Module
Collapse
No announcement yet.
Failure to update STS 2.5.2 SR1 to 2.6.0 M2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failure to update STS 2.5.2 SR1 to 2.6.0 M2

    Hi all

    For some reason Im unable to update my STS installation using the eclipse update function. Im trying to update from the milestone update site at http://dist.springsource.com/milesto...LS/update/e3.6.

    Im not sure why it says that an update is not permitted? Also, what is the wierd error on the last couple of lines about " Missing requirement: WST Common Core - Patch for 327801 ... "

    Error message follows

    Code:
     SpringSource dm Server Tools (required) will be ignored because it is already installed, and updates are not permitted.
      Spring IDE Core (required) will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite (required) will be ignored because it is already installed, and updates are not permitted.
      Spring IDE Autowire Extension (optional) will be ignored because it is already installed, and updates are not permitted.
      Spring IDE Security Extension (optional) will be ignored because it is already installed, and updates are not permitted.
      Spring IDE Web Flow Extension (optional) will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite Runtime Error Analysis Support will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite tc Server Tools will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite Tutorials will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite Grails Support will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite Maven Support will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite Roo Support will be ignored because it is already installed, and updates are not permitted.
      SpringSource Tool Suite dm Server Tools will be ignored because it is already installed, and updates are not permitted.
      Spring IDE AJDT Integration (optional) will be ignored because it is already installed, and updates are not permitted.
    Cannot complete the install because one or more required items could not be found.
      Software currently installed: Shared profile 1.0.0.1299527398023 (SharedProfile_com.springsource.sts.ide 1.0.0.1299527398023)
      Missing requirement: WST Common Core - Patch for 327801 1.0.0.v201010191306 (org.eclipse.wst.common_core.feature.patch_327801.feature.group 1.0.0.v201010191306) requires 'org.eclipse.wst.common.modulecore [1.2.3.v201010191306]' but it could not be found
      Cannot satisfy dependency:
        From: Shared profile 1.0.0.1299527398023 (SharedProfile_com.springsource.sts.ide 1.0.0.1299527398023)
        To: org.eclipse.wst.common_core.feature.patch_327801.feature.group 
    [1.0.0.v201010191306]

  • #2
    I removed the old installation and reinstalled 2.6.0 M2 from scratch......

    Comment


    • #3
      I guess the fresh install of 2.6.0.M2 worked for you? Nevertheless I will try to find out what went wrong with the update you tried before. Was it a fresh 2.5.2.SR1 installation that you tried to update to 2.6.0.M2? Or did you update that version to 2.5.2.SR1 already from another version? And did you install the WTP patch from the extension install manually some time ago?

      Cheers,
      -Martin

      Comment


      • #4
        As I recall, it wasnt a fresh 2.5.2 SR1 install, it was an install that had been updated earlier from 2.5.1 or possibly an earlier 2.5.2 version. I believe that I had installed the WTP patch from the extension installer aswell.

        Comment


        • #5
          Hi Martin,

          We have the same problem and happens when working with multiple configurations ('-configuration' execution option). If the feature you need to update was installed in the parent configuration you can't update it from child configurations.

          Probably org.eclipse.update.install.features profileProperty can help, still investigating.

          thanks, Juan.

          Comment

          Working...
          X