Announcement Announcement Module
Collapse
No announcement yet.
STS 2.6.0 M2 does not allow adding Weblogic Servers Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.6.0 M2 does not allow adding Weblogic Servers

    After installing a fresh copy of STS 2.6.0 M2 with a new workspace, I am unable to successfully add a Weblogic 10.3 server. As I have done with previous versions, I utilized the "Install additional server adapters" link to install the support for Oracle Weblogic. In M2, the install appears to be successful, but no options appear in New server dialog under Oracle for Weblogic.

    Has anyone else seen this issue, and figured out a fix for it.

    Thanks in advance.

    David

  • #2
    Is there a compatibility issue between the latest Weblogic Tools and STS?

    We are currently facing the same problem when installing the latest plugin for Oracle Enterprise Pack for Eclipse 11gR1 to deploy to the new 10.3.4 server.
    In STS 2.3.2 we are using the plugin to deploy to WLS 10.3.3 but cannot upgrade the plugin so that WLS 10.3.4 is supported.

    ######### ERROR MESSAGE ###########
    Cannot connect to keystore.
    This trust engine is read only.
    Cannot complete the install because one or more required items could not be found.
    Software currently installed: Oracle WebLogic Server Tools 1.6.0.201007221355 (oracle.eclipse.tools.galileo.weblogic.feature.gro up 1.6.0.201007221355)
    Missing requirement: Oracle Common Tools UI 2.5.0.201007221355 (oracle.eclipse.tools.common.ui 2.5.0.201007221355) requires 'bundle org.eclipse.draw2d [3.5.1,3.6.0)' but it could not be found
    Cannot satisfy dependency:
    From: Oracle WebLogic Server Tools 1.6.0.201007221355 (oracle.eclipse.tools.galileo.weblogic.feature.gro up 1.6.0.201007221355)
    To: oracle.eclipse.tools.xmlbeans.ui [2.5.0.201007221355]
    Cannot satisfy dependency:
    From: Oracle Apache XMLBeans Tools UI 2.5.0.201007221355 (oracle.eclipse.tools.xmlbeans.ui 2.5.0.201007221355)
    To: bundle oracle.eclipse.tools.common.ui [2.5.0,2.6.0)
    ######### ERROR MESSAGE ###########


    We have tried running STS 3.5 SR1 and STS 3.6 (missing property screen on "Server" conf page in STS) but the plugin seems to fail differently but still fail which makes it impossible to deploy through STS.

    Any ideas - anybody

    Is there a compatibility issue between the latest Weblogic Tools and STS?

    Comment


    • #3
      Originally posted by michartmann View Post
      Missing requirement: Oracle Common Tools UI 2.5.0.201007221355 (oracle.eclipse.tools.common.ui 2.5.0.201007221355) requires 'bundle org.eclipse.draw2d [3.5.1,3.6.0)' but it could not be found
      I think this points out the problem: If you downloaded STS as a complete package, it comes with Eclipse Helios SR2 (3.6.2), which ships a newer version of org.eclipse.draw2d. The dependency that seems to be declared in the Oracle Common Tools UI excludes that new version and explicitly requires an older one.

      I can think of two solutions here:
      - try to get a newer version of the Oracle Tools that are compatible with Eclipse 3.6, or
      - Install Eclipse Galileo SR2 for JEE Developers (3.5.2) and add STS to that via the appropriate update sites (instructions for that can be found in the installation guilde found on the download page). Then you have the older version of Eclipse that your Oracle tools seem to require.

      HTH,
      Martin

      Comment

      Working...
      X