Announcement Announcement Module
Collapse
No announcement yet.
Create a jsTestDriver plugin for the SpringSource Tool Suite Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Create a jsTestDriver plugin for the SpringSource Tool Suite

    As a grails developer I'd like to see a version of the jsTestDriver[1] plugin for SpringSource Tool Suite (STS). Since STS is built on Eclipse, and there is an eclipse version of the plugin, wouldn't it be easy to port it for STS? The Eclipse plugin doesn't work with STS. I can't say that I'm really surprised about that.

    Since I've never done any Eclipse or STS plugin development I have no idea what the scope of this request is. I'm hoping that its as simple as creating a new branch of jsTestDriver and then changing a few configs. I'm willing to attempt to port this myself, but I have absolutely no idea where to start.

    Can somebody point me in the right direction? I can't even find any documentation on creating STS specific plugins. Thanks for all your help!

    [1] http://code.google.com/p/js-test-driver/

  • #2
    RE: Create a jsTestDriver plugin for the SpringSource Tool Suite

    Well, I finally figured this out. For anyone coming after me, here's a run down of what I learned.

    First, Eclipse plugins do indeed run in STS without any modification. I feel pretty dumb for not knowing this. Moving on...

    Second, the jsTestDriver works after all. I just wasn't doing it right. I'm going to blame it on the fact that the documentation is a bit spotty. To clarify: when the docs say that the view is in Windows > Show View > Other... what they should say is that its in Windows > Show View > Other... > Javascript and is called jsTestDriver. Once I was able to activate the view, I was able to figure out the rest.

    Good luck to all of those that come after me!

    Comment


    • #3
      jsTestDriver plugin install appears to have failed

      So there's still a problem. The plugin works at home but not at work. I'm not sure what the problem is though. There are no errors in the error log. STS says that the plugin is installed, but the view in the Windows > Show View > Other... dialog is missing. There is also no js test driver preference screen either.

      Does anyone have any thoughts or ideas about what might be causing this? Has anyone else had a similar problem with another plugin? Hours of googling hasn't shed any light on my problem.

      Thanks!

      Comment


      • #4
        Can you take a look at the console view, choosing the OSGi Host console, tryping in "ss" for "short status" and looking at the state of your jsTestDriver bundle? Is it resolved or active, or just "installed"? If it is just "installed", there seem to be some dependencies missing...

        Comment


        • #5
          RE: OSGi Console

          First let me say thanks for your help Martin! Here's what the OSGi Console reported about the plugin.

          1057 INSTALLED com.google.eclipse.javascript.jstestdriver.core_1. 1.1.e
          1058 INSTALLED com.google.eclipse.javascript.jstestdriver.ui_1.1. 1.e

          Is there a way to figure out what dependancies might be missing?

          Comment


          • #6
            Type "diag 1057" or "diag 1058" in the console and the runtime will tell us what dependencies are missing...

            Comment


            • #7
              RE: OSGi Console

              Thanks for your quick response! So I did that and got this error. I tried changing my Installed JRE in the preferences menu to Java 1.6. I cleaned and rebuilt my project. I then tried uninstalling and reinstalling the plugin to see if that would help. No such luck.

              1268 INSTALLED com.google.eclipse.javascript.jstestdriver.core_1. 1.1.e
              1269 INSTALLED com.google.eclipse.javascript.jstestdriver.ui_1.1. 1.e

              osgi> diag 1268
              reference:filelugins/com.google.eclipse.javascript.jstestdriver.core_1. 1.1.e.jar [1268]
              Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6

              osgi> diag 1269
              reference:filelugins/com.google.eclipse.javascript.jstestdriver.ui_1.1. 1.e.jar [1269]
              Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
              Direct constraints which are unresolved:
              Missing required bundle com.google.eclipse.javascript.jstestdriver.core_1. 1.1.

              My Preferences > Java > Installed JRE is set to: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

              So I'm guessing that there is a gap in my understanding of what an Installed JRE is used for and where the Bundle-RequiredExecutionEnvironment is looking to find a JVM. Your thoughts?

              Comment


              • #8
                I guess you are running on a Mac and it seems like your STS is running a 1.5.0 JDK or so. I have no idea why exactly your STS is running on top of that JDK, but you can explicitly set the JRE to use for running STS by opening the STS.app (show content) and change the settings inside the Info.list. You will see the path to the java command in there (somewhere at the end).

                HTH,
                Martin

                Comment

                Working...
                X