Announcement Announcement Module
Collapse
No announcement yet.
Initializing Java Tooling (1%) and STS command-line options Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Initializing Java Tooling (1%) and STS command-line options

    I start work this morning and am unable to do anything. STS is locking up on me constantly. It was working Friday: not working this morning. There were a couple of different ways this manifested, but eventually I got to this message just displaying and blocking:

    Code:
    Initializing Java Tooling (1%)
    I can bring up the Progress window and watch this task not making any progress directly, which is not very helpful, but there's that big stylish red STOP button next to it, so I push that and that serves to just lock up STS across the board and cause me to need to kill the process and start all over again.

    So what causes this sort of thing? It's a not uncommon issue from what I've found googling around about it.

    Now, I know it's not an STS-specific error, and that's not what I'm asking about here. But one of the most commonly prescribed workarounds or solutions for Eclipse is to run like this:

    Code:
    eclipse.exe -clean
    I tried this with sts.exe and it doesn't seem to have any effect or be noticed at all. So what command-line options does sts.exe have? How does one do the equivalent of the direct Eclipse command-line options?

    And does anyone have any helpful ideas for fixing the Initializing Java Tooling freeze?

  • #2
    sts.exe -clean should be doing what is expected. It may be that your particular deadlock is not being solved through a -clean.

    Have you installed the patch for WTP? You can find it on the extensions page under "Patch for Bug 327801". To install, you probably want to start your sts with a new and empty workspace to get around the startup freeze.

    If installing this patch does not work, then can you grab a stack dump of your frozen STS and paste it here? (use jps and then jstack).

    Comment


    • #3
      Andrew,

      Thanks for the response. Is there a site archive for the WTP fix? We're stuck behind a no-go firewall, so we can't download plugins, etc., through the regular extensions procedure (no, I'm not a fan of this system and it wasn't my idea ). If I can download and hand-carry it over to our firewalled dev environment, then I can give that a try.

      If that doesn't work, then I'll ask you what you mean by "use jps and then jstack"

      Comment


      • #4
        In this bug report, there is a hotfix for the problem. Please follow the directions there to install:

        https://bugs.eclipse.org/bugs/show_bug.cgi?id=327801

        jps and jstack are two tools shipped with the JDK that make it easy to grab stack traces of a running java process. Run jps to get a list of all java processes running on your system. And then jstack on the specific process to print the stack.

        Comment

        Working...
        X