Announcement Announcement Module
Collapse
No announcement yet.
M2E and Subversion not working propperly in 2.5.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • M2E and Subversion not working propperly in 2.5.2

    Today I tried 2.5.2 with Subversive plugin (as usual).

    As m2eclipse 0.12.0 doesn't support nested modules anymore, I removed my projects from workspace and tried to import from svn, but this does not work.

    File > Import > Check out Maven projects from SCM > SCM Type drop down is completely empty. (subversive is installed from dashboard and is working)

    Also, trying to import from SVN Repository Explorer > Find / Check out as.. > "Check out as project configured using new New Project Wizard" is grayed out and not selectable....

    Switched back to 2.5.1 for now.

    Platform is OSX 10.6.6, Eclipse Cocoa.

  • #2
    You probably just need the m2e Subversive connector, which can be installed via this update site URL:

    https://repository.sonatype.org/cont....201101251426/

    That will allow you to right-click on any Maven project in the SVN Repository Explorer and choose 'Checkout as Maven Project...'.

    Comment


    • #3
      The STS included Subversive Connector is also 0.12.0. Is there a difference in those two?

      Has anyone tested Subversive in 2.5.2? We tried on 3 machines (all OSX). Same problem on all of them.
      Subversive checkout/import as maven project does not work.
      Last edited by robertoschwald; Feb 16th, 2011, 05:57 AM.

      Comment


      • #4
        There are 2 components you need:

        1) Subversive itself, which you install via the Dashboard in STS.

        2) The m2e Subversive configurer/connector. This is what allows you to checkout projects as Maven projects. This isn't installed in STS by default, isn't installed when you install Subversive via the Dashboard, and to my knowledge, can only be installed via the URL I gave you in my previous post.

        I'm using 2.5.2 and checkout as Maven project didn't work until I installed the m2e configurer.

        Comment

        Working...
        X