Announcement Announcement Module
Collapse
No announcement yet.
2.6.0M1 and Exception in opening zip file Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2.6.0M1 and Exception in opening zip file

    I get this in my error log with a fresh install of STS 2.6.0M1:
    eclipse.buildId=2.6.0.201101271000-M1
    java.version=1.5.0_26
    java.vendor=Apple Inc.
    BootLoader constants: OS=macosx, ARCH=ppc, WS=cocoa, NL=sv_SE
    Framework arguments: -product com.springsource.sts.ide -keyring /Users/mik/.eclipse_keyring -showlocation
    Command-line arguments: -os macosx -ws cocoa -arch ppc -product com.springsource.sts.ide -keyring /Users/mik/.eclipse_keyring -showlocation

    !ENTRY org.eclipse.osgi 4 0 2011-01-31 09:31:11.525
    !MESSAGE
    !STACK 0
    java.util.zip.ZipException: Exception in opening zip file: /Applications/springsource2.6.0M1/sts-2.6.0.M1/plugins/com.springsource.osgi.medic_1.0.0.RELEASE.jar
    I get about 110 different "java.util.zip.ZipException: Exception in opening zip file" for different packages and also at the end "java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry".

    I suppose I need to try a nightly build, but is this a common error? What could be the cause?

  • #2
    Hi,

    can you please download the .tar.gz archive instead. We recently moved our build machine and seemed to have caused this issue during creation of the installer. Sorry for the hassle.

    See https://issuetracker.springsource.com/browse/STS-1528

    Thanks, Christian

    Comment


    • #3
      the tar archive works

      Using the tar-archive did help.

      Comment

      Working...
      X