Announcement Announcement Module
No announcement yet.
after upgrade to STS 2.5.2 unable to update / GRAILS Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • after upgrade to STS 2.5.2 unable to update / GRAILS

    I recently updated to STS 2.5.2 and I am no longer able to work within a GRAILS 1.3.6 project. When I try to install plugins I get a message stating unable to update I even tried a fresh install with the same result. I've even tried with a new project on the fresh install and still get the same message when trying to install grails plugins.

    Does anyone get this message after upgrading?

    See details below.
    Exception thrown when trying to update ''
    Resource is out of sync with the file system: '/myproject/'.

    See below...on a new project called test the first time I try and install plugins I get the following stack trace.
    Exception thrown when trying to update ''
    Command failed, see details for output.
    Welcome to Grails 1.3.6 -
    Licensed under Apache Standard License 2.0
    Grails home is set to: C:\springsource2\grails-1.3.6\

    Base Directory: C:\workspace3\test
    Resolving dependencies...
    Dependencies resolved in 1742ms.
    Running script C:\springsource2\grails-1.3.6\scripts\Compile.groovy
    Environment set to development
    Setting non-interactive mode
    Plugin [multi-tenant-core-1.0.3] not installed. ...
    Resolving new plugins. Please wait... ...
    Installing zip C:\Users\Dad\.ivy2\cache\org.grails.plugins\multi-tenant-core\zips\ ...
    [mkdir] Created dir: C:\Users\Dad\.grails\1.3.6\projects\test\plugins\m ulti-tenant-core-1.0.3
    [unzip] Expanding: C:\Users\Dad\.ivy2\cache\org.grails.plugins\multi-tenant-core\zips\ into C:\Users\Dad\.grails\1.3.6\projects\test\plugins\m ulti-tenant-core-1.0.3
    Installed plugin multi-tenant-core-1.0.3 to location C:\Users\Dad\.grails\1.3.6\projects\test\plugins/multi-tenant-core-1.0.3. ...
    Plugin dependency [falconeUtil] not found. Attempting to resolve... ...
    Resolving plugin falcone-util. Please wait...

    Installing zip C:\Users\Dad\.ivy2\cache\org.grails.plugins\falcon e-util\zips\ ...
    [mkdir] Created dir: C:\Users\Dad\.grails\1.3.6\projects\test\plugins\f alcone-util-1.0
    [unzip] Expanding: C:\Users\Dad\.ivy2\cache\org.grails.plugins\falcon e-util\zips\ into C:\Users\Dad\.grails\1.3.6\projects\test\plugins\f alcone-util-1.0
    Installed plugin falcone-util-1.0 to location C:\Users\Dad\.grails\1.3.6\projects\test\plugins/falcone-util-1.0. ...
    Executing falcone-util-1.0 plugin post-install script ...
    Plugin falcone-util-1.0 installed
    [delete] Deleting directory C:\workspace3\test\web-app\WEB-INF\classes
    [delete] Deleting directory C:\workspace3\test\target\classes
    [delete] Deleting directory C:\Users\Dad\.grails\1.3.6\projects\test\plugin-classes
    [delete] Deleting directory C:\Users\Dad\.grails\1.3.6\projects\test\resources
    Resolving plugin JAR dependencies ...
    Executing multi-tenant-core-1.0.3 plugin post-install script ...
    Plugin multi-tenant-core-1.0.3 installed
    Plugin provides the following new scripts:
    grails create-data-source-map
    grails create-dns-map
    Executing . plugin uninstall script ...
    [delete] Deleting directory C:\Users\Dad\.grails\1.3.6\projects\test\plugins\f alcone-util-1.0
    [mkdir] Created dir: C:\Users\Dad\.grails\1.3.6\projects\test\plugin-classes
    [groovyc] Compiling 33 source files to C:\Users\Dad\.grails\1.3.6\projects\test\plugin-classes
    [groovyc] org.codehaus.groovy.control.MultipleCompilationErr orsException: startup failed:
    [groovyc] Compile error during compilation with javac.
    [groovyc] C:\Users\Dad\.grails\1.3.6\projects\test\plugins\m ulti-tenant-core-1.0.3\src\java\grails\plugin\multitenant\core\Curr package com.infusion.util.event does not exist
    [groovyc] import com.infusion.util.event.EventBroker;
    [groovyc] ^
    [groovyc] C:\Users\Dad\.grails\1.3.6\projects\test\plugins\m ulti-tenant-core-1.0.3\src\java\grails\plugin\multitenant\core\Curr cannot find symbol
    [groovyc] symbol : class EventBroker
    [groovyc] location: class grails.plugin.multitenant.core.CurrentTenantThread Local
    [groovyc] private EventBroker eventBroker;
    [groovyc] ^
    [groovyc] C:\Users\Dad\.grails\1.3.6\projects\test\plugins\m ulti-tenant-core-1.0.3\src\java\grails\plugin\multitenant\core\Curr cannot find symbol
    [groovyc] symbol : class EventBroker
    [groovyc] location: class grails.plugin.multitenant.core.CurrentTenantThread Local
    [groovyc] public void setEventBroker(EventBroker eventBroker)
    [groovyc] ^
    [groovyc] 3 errors
    [groovyc] 1 error
    ... done
    Error executing script Compile: : Compilation Failed
    : Compilation Failed
    at gant.Gant$_dispatch_closure5.doCall(Gant.groovy:39 1)
    at gant.Gant$_dispatch_closure7.doCall(Gant.groovy:41 5)
    at gant.Gant$_dispatch_closure7.doCall(Gant.groovy)
    at gant.Gant.withBuildListeners(Gant.groovy:427)
    at gant.Gant.this$2$withBuildListeners(Gant.groovy)
    at gant.Gant$this$2$withBuildListeners.callCurrent(Un known Source)
    at gant.Gant.dispatch(Gant.groovy:415)
    at gant.Gant.this$2$dispatch(Gant.groovy)
    at gant.Gant.invokeMethod(Gant.groovy)
    at gant.Gant.executeTargets(Gant.groovy:590)
    at gant.Gant.executeTargets(Gant.groovy:589)
    Caused by: : Compilation Failed
    at org.codehaus.groovy.ant.Groovyc.compile(Groovyc.ja va:910)
    at org.codehaus.groovy.ant.Groovyc.execute(Groovyc.ja va:605)
    at e(
    at _GrailsCompile_groovy$_run_closure4_closure10.doCa ll(_GrailsCompile_groovy:117)
    at _GrailsCompile_groovy$_run_closure4_closure10.doCa ll(_GrailsCompile_groovy)
    at _GrailsSettings_groovy$_run_closure10.doCall(_Grai lsSettings_groovy:280)
    at _GrailsSettings_groovy$ Settings_groovy)
    at _GrailsCompile_groovy$_run_closure4.doCall(_Grails Compile_groovy:104)

  • #2

    I've raised to track this. It appears there is a problem with the plugin manager if you install a plugin that pulls in another plugin. (the way multi-tenant-core pulls in falcone-util). You can install that via the prompt for now, or install falcone-util and multi-tenant-core both at the same time in the plugin manager.

    There were changes in this area recently, so it is unfortunately a regression.

    Andy Clement
    SpringSource, a division of VMware


    • #3
      thanks Andy for the quick response. I am glad to hear it is just not me and there is a workaround.