Announcement Announcement Module
Collapse
No announcement yet.
Error starting static Resources > java.lang.IllegalArgumentException Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error starting static Resources > java.lang.IllegalArgumentException

    Hi there,

    I am developing a Spring Web MVC project with SpringSource (latest version).

    Everything was working just fine, but today, after stopping the server to perform some changes in the web app configuration, I can't start the server anymore.

    It says: Error starting static Resources > java.lang.IllegalArgumentException

    I have tried "Clean", "Clean Tomcat Work Directory", Deleting & adding again the server, restarting the machine (in case the tomcat server terminated incorrectly and the port was still in use), etc.

    This is my log:

    Code:
    Severe: Error starting static Resources
    java.lang.IllegalArgumentException: Documento bas /Users/lserrano/Documents/workspace-sts-2.3.2.RELEASE/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/springtest does not exist or is not a readable directory
    	at org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:142)
    	at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:4249)
    	at org.apache.catalina.core.StandardContext.start(StandardContext.java:4418)
    	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
    	at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
    	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
    	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
    	at org.apache.catalina.core.StandardService.start(StandardService.java:519)
    	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
    	at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
    	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
    20-ago-2010 10:26:07 org.apache.catalina.core.StandardContext start
    GRAVE: Error in resourceStart()
    20-ago-2010 10:26:07 org.apache.catalina.core.StandardContext start
    GRAVE: Error getConfigured
    20-ago-2010 10:26:07 org.apache.catalina.core.StandardContext start
    GRAVE: Falló en arranque del Contexto [/springtest] debido a errores previos
    20-ago-2010 10:26:07 org.apache.catalina.core.StandardContext stop
    INFO: No se ha arrancado el Contenedor org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/springtest]
    20-ago-2010 10:26:07 org.apache.coyote.http11.Http11Protocol start
    INFO: Arrancando Coyote HTTP/1.1 en puerto http-8080
    20-ago-2010 10:26:07 org.apache.jk.common.ChannelSocket init
    INFO: JK: ajp13 listening on /0.0.0.0:8009
    20-ago-2010 10:26:07 org.apache.jk.server.JkMain start
    INFO: Jk running ID=0 time=0/23  config=null
    20-ago-2010 10:26:07 org.apache.catalina.startup.Catalina start
    INFO: Server startup in 456 ms
    Anyone has run into such situation? I have checked my Tomcat 6 (not Springsource Server) config files and non of them have a single reference to a missing application. All .jar files from SpringSource tc Server "lib" and "lib/ext" are present. Well, as a matter of fact, it was working but at some point it just didn't work anymore, so it is not a matter of missing jar's, I guess.

    Thank you.

  • #2
    Solved

    Hey, I just fixed it by doing this:

    * Removing the project from the server
    * Maven -> Update Project Configuration
    * Run As -> Maven clean
    * Run As -> Maven build

    Cheers,

    Comment

    Working...
    X