Announcement Announcement Module
Collapse
No announcement yet.
(STS 2.3.3M2 ) The following connectors are not available: Grails Support Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • (STS 2.3.3M2 ) The following connectors are not available: Grails Support

    I have the following error, when trying to install Grails Support.

    Problems occurred while performing installation: The following connectors are not available: Grails Support (id=com.springsource.sts.grails.feature.group, site=http://dist.springsource.com/snapshot/TOOLS/nightly/e3.6)
    I have already installed Groovy Support and Grails itself via extension manager so it's not networking problem.

    The most strange thing:
    I have another error when i've tried to install Grails Support at first time
    There is no repository available on: http://dist.springsource.com/snapsho...S/nightly/e3.6
    But after i reloaded all repositories(on preferences page) i got exception described on the top.

  • #2
    Solved: manually installed via "Install new software" menu from http://dist.springsource.com/milesto...LS/update/e3.6

    Comment


    • #3
      STS 3.3.2 M2, grails support.

      Thank you ! this is the right repository url. It works for me.

      Comment


      • #4
        Real solution...

        Using 2.3.3m2, the real solution I found was install the codehaus groovy-eclipse extension, then after restart of STS, install springsource grails plugin. It does NOT handle dependencies correctly.

        Comment


        • #5
          Hi,

          this has been fixed and should now work when installing the Grails Support for the extension install.

          Christian

          Comment


          • #6
            From your comments, it sounds like you made a change on the server side. I retested this again.

            On a fresh install of STS 2.3.3M2, using a fresh workspace, if I click to install just the 'grails support (springsource)' extension and hit install, I get a dialog box that says

            The following connectors are not available: Grails Support
            Proceed with the installation anyways?

            If you hit yet, you get another error box, click okay and its stuck on 'Computing prerequisite plan'

            Unfortunately, if I install 'Groovy-eclipse' first, it still doesn't work fine.

            Error message says:
            Problems occurred while performing installation: Operation details
            Operation details
            Cannot complete the request. See the error log for details.


            Last error in the log file:
            !SESSION 2010-07-23 13:40:41.644 -----------------------------------------------
            eclipse.buildId=2.3.3.201007151000-M2
            java.version=1.6.0_18
            java.vendor=Sun Microsystems Inc.
            BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
            Framework arguments: -product com.springsource.sts.ide
            Command-line arguments: -os linux -ws gtk -arch x86_64 -product com.springsource.sts.ide

            !ENTRY org.eclipse.equinox.p2.core 4 0 2010-07-23 13:41:46.253
            !MESSAGE Provisioning exception
            !STACK 1
            org.eclipse.equinox.p2.core.ProvisionException: No repository found at http://dist.springsource.com/snapsho...S/nightly/e3.6.
            at org.eclipse.equinox.internal.p2.repository.helpers .AbstractRepositoryManager.fail(AbstractRepository Manager.java:392)
            at org.eclipse.equinox.internal.p2.repository.helpers .AbstractRepositoryManager.loadRepository(Abstract RepositoryManager.java:676)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.MetadataRepositoryManager.loadRepository(Metadat aRepositoryManager.java:96)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.MetadataRepositoryManager.loadRepository(Metadat aRepositoryManager.java:92)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.CompositeMetadataRepository.addChild(CompositeMe tadataRepository.java:153)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.CompositeMetadataRepository.<init>(CompositeMeta dataRepository.java:106)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.CompositeMetadataRepositoryFactory.load(Composit eMetadataRepositoryFactory.
            java:122)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.MetadataRepositoryManager.factoryLoad(MetadataRe positoryManager.java:57)
            at org.eclipse.equinox.internal.p2.repository.helpers .AbstractRepositoryManager.loadRepository(Abstract RepositoryManager.java:747)
            at org.eclipse.equinox.internal.p2.repository.helpers .AbstractRepositoryManager.loadRepository(Abstract RepositoryManager.java:652)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.MetadataRepositoryManager.loadRepository(Metadat aRepositoryManager.java:96)
            at org.eclipse.equinox.internal.p2.metadata.repositor y.MetadataRepositoryManager.loadRepository(Metadat aRepositoryManager.java:92)
            at org.eclipse.mylyn.internal.discovery.ui.PrepareIns tallProfileJob.addRepositories(PrepareInstallProfi leJob.java:309)
            at org.eclipse.mylyn.internal.discovery.ui.PrepareIns tallProfileJob.computeInstallableUnits(PrepareInst allProfileJob.java:134)
            at org.eclipse.mylyn.internal.discovery.ui.PrepareIns tallProfileJob.run(PrepareInstallProfileJob.java:8 9)
            at org.eclipse.jface.operation.ModalContext$ModalCont extThread.run(ModalContext.java:121)
            !SUBENTRY 1 org.eclipse.equinox.p2.metadata.repository 4 1000 2010-07-23 13:41:46.254
            !MESSAGE No repository found at http://dist.springsource.com/snapsho...S/nightly/e3.6.

            Comment


            • #7
              I created a jira ticket to track this, but accidentally put the wrong version number on it. Its an issue with 2.3.3 not 2.3.2. Jira won't let me change it and I didn't want to create another bug for this. https://jira.springsource.org/browse/IDE-1134

              Comment


              • #8
                Working as of 'now'...

                Doing another test and it seems to be working now. Did you make a change since my last test? If so, what was changed?

                Comment


                • #9
                  I tried to install Groovy and Grails support by checking both "Groovy Eclipse" and "Grails Support" in the Extensions tab and got the following error:

                  Problems occurred while performing installation: The following connectors are not available: Groovy Eclipse (id=org.codehaus.groovy.eclipse.feature.feature.gr oup, site=http://dist.springsource.com/release/TOOLS/third-party/groovy-grails/e3.6/)

                  If I install only Groovy Eclipse, it installs fine.

                  Comment


                  • #10
                    Hi,

                    I've updated the extension install listing again to avoid this "No connector found issue". Please try again. All issues should be solved now.

                    Regards, Christian

                    Comment


                    • #11
                      Connectors are Not Available

                      Is this an issue again? I downloaded and installed STS-2.3.3.M2-e3.6 for 64-bit Windows yesterday. I was able to install the Subclipse extension successfully. However, when I attempt to install the Grails Support extension I receive the following question:

                      The following connectors are not available: Grails Support
                      Proceed with the installation anyways?
                      After clicking, 'No' I capture the following text in the error log:

                      Problems occurred while performing installation: The following connectors are not available: Grails Support (id=com.springsource.sts.grails.feature.group, site=http://dist.springsource.com/release/TOOLS/third-party/groovy-grails/e3.6)
                      The following connectors are not available: Grails Support (id=com.springsource.sts.grails.feature.group, site=http://dist.springsource.com/release/TOOLS/third-party/groovy-grails/e3.6)

                      Any ideas?

                      Comment


                      • #12
                        I am getting the same error installing the Grails Support extension. I downloaded 2.3.3.M2-e3.6-win32 on 7/29 and installed today. I added the Grails extension, and restarted. Do not have the Groovy Eclipse extension (errors). Tried the Grails Support extension from the Dashboard and get the error.

                        Comment


                        • #13
                          I tried to manually install it from Site: http://dist.springsource.com/release/TOOLS/update/e3.6. I get two errors, perhaps this is the underlying problem.

                          (1) On the 'Available Software' screen, if I click Add.. to view the site list, other springsource & codehaus links appear ok, but this link states "This repository is currently not available."

                          (2) If I just select it from the "Work with:" box, it states "Could not find http://dist.springsource.com/release/TOOLS/update/e3.6"

                          Comment


                          • #14
                            Getting the same error as snowmanjack and bwallace who are attempting to use STS 2.3.3.M2 on Eclipse 3.6. I'm working from a fresh install I just downloaded from the Spring site today.

                            Comment


                            • #15
                              Same problem too

                              Just downloaded 2.3.3.M2 with Eclipse 3.6 - clean install and getting the same result as others.

                              Comment

                              Working...
                              X