Announcement Announcement Module
Collapse
No announcement yet.
SpringIDE V. 1.2.3 Update failed Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpringIDE V. 1.2.3 Update failed

    Hi,

    I updated my SpringIDE plugins to the latest version (V1.2.3) by using the software updates from the Eclipse (V3.1) Help menu.

    Now, when I try to 'Add Spring Project Nature' to an existing project, the following exception is reported in Eclipse's .log file:

    Code:
    java.lang.NoSuchMethodError: org.springframework.ide.eclipse.core.SpringCoreUtils.isSpringProject(Lorg/eclipse/core/resources/IProject;)Z
    	at org.springframework.ide.eclipse.ui.internal.actions.AddRemoveNature.run(AddRemoveNature.java:71)
    	at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:246)
    	at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
    	at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
    	at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
    	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
    	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
    	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3080)
    	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2713)
    	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
    	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
    	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
    	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
    	at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
    	at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:585)
    	at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    	at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    	at org.eclipse.core.launcher.Main.run(Main.java:973)
    	at org.eclipse.core.launcher.Main.main(Main.java:948)
    What could I have done wrong?

    Thanks,
    John

  • #2
    Re: SpringIDE V. 1.2.3 Update failed

    John,

    it seems to be a glitch in your installation of Spring IDE after your update. The core plugin isn't up-to-date (you're using an outdated version of the class SpringCoreUtils).

    Please delete the Spring IDE stuff (folders starting with "org.springframework.eclipse.ide.*") from your installation folders (../eclipse/features/ and ../eclipse/plugins/) and re-install Spring IDE with the update manager.

    Sorry for this inconvinience.

    Cheers,
    Torsten

    Comment


    • #3
      Torsten,jdubchak

      It isn't enoug sometime - I have to delete ECLIPSE_HOME/configuration/org.eclipse.* when
      change existing plugins - eclipse 3.1 have any buggy caching and changing only (adn -clean) don't help

      regards

      Comment

      Working...
      X