Announcement Announcement Module
No announcement yet.
STS 2.3.2 - issues downloading mvc template Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.3.2 - issues downloading mvc template

    I am receiving an error message when I try and set up a new Spring project with the mvc template.

    "Download of template 'org.springframework.temoplates.mvc' failed"

    Can someone please suggest why? I know its not my end of the web, as I've tried it from different machines within different ISPs.

    Please help!

  • #2
    Further to the earlier post, I too am having the same problem when trying to download the template for the Simple Spring Batch project.

    In my case, the new template project wizard inside the Springsource Tool Suite version 2.3.2.RELEASE hangs whilst trying to download If I put this url into a browser, I can download the file ok.

    I'm behind a proxy, however I have the appropriate settings in window -> preferences -> general -> network connections.

    Any help with this would be appreciated.

    Alternatively, now that I've downloaded the template zip file. Is it possible to install this manually?

    Many thanks in advance.


    • #3
      I went through exactly the same steps, inc downloading the zip file etc.

      I then closed the Welcome tab and was faced with a familiar looking IDE set of panes. I then went through the File -> New -> Spring Template Project etc and hey presto it worked!

      So, closing the Welcome tab did it for me!


      • #4
        I got it working.

        I faced the same problem. unable to download mvc template.

        I checked my proxy settings in

        window -> preferences -> general -> network connections

        and also changed the maven's proxy settings in settings.xml file.

        Then i changed the Active provider to Native (in Network connections) and tried to create a mvc project. It worked for me. Nearly i spent 5 hours. I am not sure this will work for others but i'm happy it worked.

        Hope it helps someone.
        Last edited by smomula; Aug 25th, 2010, 09:03 AM. Reason: Hope it helps someone.


        • #5
          No outside network connection at all

          Is it possible to make this work? We are in a secured development environment that has no connectivity to the Internet. Obviously, configuring a proxy won't help this. We need to be able to install the Spring project templates manually. Can this be done?


          • #6
            Could not download spring mvc template


            I did checked my network connection (i tried using all 3 options - direct, native, manual). I also added proxy settings to maven's settings.xml. But still i am getting the same error and downloading of spring mvc project is still failing.
            Can anyone suggest any workarounds?



            • #7

              You can find this info by using search box in the top of website with some keywords related before posting questions.


              • #8

                Your reply did not help me at all. I did search and tried suggested option before posting. If you know any workarounds, please let me know.



                • #9
                  I am also in a secure development environment... has anyone installed org.springframework.templates.mvc manually. I haven't been able to find it anywhere.


                  • #10

                    There are two issues here. If you have problems with accessing the network due to configuration problems, please refer to the Eclipse network preferences and try to configure that for your environment.

                    The second question is whether its possible to use the templates without an internet connection at all. There are two answers to this:
                    First, once you have used a template, its data is cached locally. So you can go offline once you used the template once. Second, there is no easy way to download the templates manually and use them from within STS. But (as reported here: there is a complicated solution, doing something like creating custom templates that are just copies of the real templates. Aside of that, I will add this as a feature request to the project templates, so that we can take care of making this easier when working on the project template feature.



                    • #11
                      I also faced the same issue. After some trial and error, i finally figured out how to get it working. Following were the steps followed:

                      1. Open STS
                      1.1 Go to File -> New -> Spring Template Project
                      1.2 Click Refresh
                      1.3 Now close STS
                      2. Navigate to STS home folder i.e. the installation folder
                      2.1 Search for descriptors.xml. In my case it was in STS_HOME\configuration\org.eclipse.osgi\bundles\33 \1\.cp
                      2.2 Open the file are search for the tag describing the template we are looking for. In my case it was org.springframework.templates.mvc. If there are mutiple versions, pick the one with latest version
                      2.3 Change the local attribute value from false to true
                      2.4 The tag contains the URL from where we can download the template file. In my case it was
                      3. Download the template file
                      3.1 Extract the contents of the template file to a folder with the name of the template with version under STS_WORKSPACE\.metadata\.sts\content e.g. STS_WORKSPACE\.metadata\.sts\content\org.springfra mework.templates.mvc-3.1.2
                      4. Open STS and now we should be able to use the template as expected

                      Hope this helps.

                      Nibin Jacob Panicker


                      • #12
                        Hey Nibin!

                        Thanks for posting your steps here!!!



                        • #13
                          I had exactly same problem as others, you dont actually have to modify anything to change download path etc. The problem is spring tool do not have permission to download those files. Just run spring tools with administrator privilege (Right click in menu and select "Run as a administrator") and you should be able to download all template projects.

                          You only need to do this once for all templates, once you will have all of them downloaded you can launch Spring tools normally and still create template projects thereafter.

                          Hope this will help.