Announcement Announcement Module
Collapse
No announcement yet.
Unable to install STS 2.3.2 into Eclipse 3.5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to install STS 2.3.2 into Eclipse 3.5

    I've installed a fresh copy of Eclipse 3.5 Java EE IDE for Web Developers (build 20090621-0832) on Mac OS X 10.6.3. The only updates I've made were to install the latest Hibernate Tools and Subclipse.

    I am now trying to install STS 2.3.2. I disabled all update sites, then imported and enabled the updates sites specified in http://dist.springsource.com/release.../bookmarks.xml. After selecting the modules to install (as specified in the 2.3.2 install instructions) and clicking Next on the install wizard, the following error is reported:

    Code:
    Cannot complete the install because one or more required items could not be found.
      Software being installed: Spring IDE AJDT Integration (optional) 2.3.2.201003220227-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 2.3.2.201003220227-RELEASE)
      Missing requirement: Spring IDE AJDT Integration (optional) 2.3.2.201003220227-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 2.3.2.201003220227-RELEASE) requires 'org.eclipse.contribution.xref.feature.group [2.0.1,3.0.0)' but it could not be found
    What am I doing wrong, or do I need to update something else first?

    Thanks!

    -Jeff

  • #2
    Hi Jeff,

    make sure that "Contact all update sites" is checked in the install dialog. If that does not help you can try to manually install the Cross References tool (XRef) feature from the SpringSource Update Site for Eclipse 3.5 (Dependencies) repository and then retry installing STS.

    Hope that helps.

    Steffen

    Comment

    Working...
    X